Allgemeines

GAIA-MV professional Handbuch

Einleitung

Allgemeines

Diese Dokumentation beschreibt die Basisfunktionalitäten von GAIA-MVprofessional. Abhängig von der Systemkonfiguration und den eingebundenen Daten sind gegebenenfalls nicht alle aufgeführten Funktionen zur Nutzung verfügbar.

Die Abbildungen in dieser Dokumentation können sich leicht von der Anwendung unterscheiden.

Gründe hierfür können sein:

- Funktionen, die nur mit entsprechender Berechtigung verfügbar sind

- Funktionen, die so nur bei eingeschränkten Berechtigung verfügbar sind

- Änderungen von Symbolen und/oder Texten infolge der Weiterentwicklung und Optimierung der Anwendung.

GAIA-MV ist fester Bestandteil des GeoPortal.MV (http://www.geoportal-mv.de). Die meisten darin enthaltenen Geodatenbestände und Geowebdienste sind für die Visualisierung frei zugänglich. Einige Daten und Dienste sind bestimmten Nutzergruppen vorbehalten; ihre Nutzung muss beantragt werden.

GAIA-MV wird weiterhin für Fachanwendungen im Intranet von Behörden oder Unternehmen eingesetzt. Die in solchen Fachanwendungen integrierten Karten sind dabei nicht Bestandteil der Lösung. Sie können jedoch je nach Anforderungsprofil in die Lösung integriert werden. Für die Beschaffung und Nutzung der Kartengrundlagen sind die Nutzungsbedingungen der Datenerzeuger zu berücksichtigen.

Stand: 05 / 2019

© DVZ-MV GmbH 2005-2019


Allgemeine Informationen zu GAIA-MV

Einleitung

Allgemeine Informationen zu GAIA-MV

GAIA bedeutet nach der griechischen Götterlehre „die Leben erzeugende und Leben tragende Erde“.

GAIA-MV (GeoAccessInternetApplication-Mecklenburg-Vorpommern) ist ein Baukastensystem zum Entwickeln von webbasierten Anwendungen für das Visualisieren und Auswerten von Geodaten. Mit seinen Elementen können anwendungsbezogene Fachapplikationen direkt auf die Nutzerbedürfnisse abgestimmt und erstellt werden. Außerdem ermöglicht das System die Abbildung von Prozessen. Komplizierte Workflows werden digital unterstützt und können mit geographischen Informationen verknüpft werden.

GAIA-MV eignet sich damit hervorragend zur Herstellung von Integrationsplattformen im Umfeld von E-Governmentlösungen im Intra- und im Internet.

Über einen Browser greifen alle Nutzer auf die WebGIS-Anwendung zu. Geodaten werden - unabhängig vom Ort ihrer Entstehung und ihrer originären Aufbewahrung - über eine gemeinsame Plattform bereitgestellt und analysiert. Damit werden sie interoperabel und die Nutzung in Planungs- und Entscheidungsprozessen selbstverständlich.

GAIA-MVprofessional unterstützt mit umfangreichen Funktionalitäten die Lösung einfacher bis komplizierter Aufgaben und Workflows. Dazu gehören unter Anderem das Suchen, Navigieren, Messen, Zeichnen, Abfragen und Drucken bis hin zum Erfassen, Editieren und Abspeichern von Geometrieobjekten und Attributen.

Eine primäre Erfassung und Pflege von GIS-Massen-Datenbeständen oder eine komplexe Analyse gehört in der Regel nicht zur Aufgabe der Nutzergruppe von GAIA-MV.

GAIA-MVlight unterstützt sowohl einfache Standardfunktionen zum Betrachten als auch einfaches Abfragen von Geodaten.

Die folgenden Ausführungen beziehen sich auf die Beschreibung der Anwendung GAIA-MVprofessional.


Systemvoraussetzungen

Einleitung

Systemvoraussetzungen

Der Zugriff auf die Daten sowie die Nutzung der angebotenen Funktionalitäten wurden mit den gängigen Standard-Web-Browsern (MS Internet Explorer Version 11 und 12, Mozilla Firefox ab 32 oder Opera ab 8.51, Safari, Google Chrome, Konqueror) getestet. Auf dem lokalen PC muss keine weitere Software installiert werden. Die Bedienung per Touchscreen (Tablets) ist möglich und wird unterstützt.

Erforderliche Einstellungen:

JavaScript muss im Browser aktiviert sein.

Der Popup-Blocker sollte so eingestellt sein, dass Popups von der GAIA- MVprofessional-Seite zugelassen werden. Andernfalls ist die Anzeige von in GAIA integrierten Dialogen (z.B.: Anzeige der Abfrageergebnisse, erweiterter Abfragemanager, Geometrie- und Sachdateneditor) nicht möglich.


Sicherheitseinstellungen

Einleitung

Sicherheitseinstellungen

In der Basisversion ist keine Herabsetzung der Sicherheit im Browser notwendig. In einigen Fachmodulen müssten diese Einstellungen angepasst werden, um ein Höchstmaß an Interaktivität zu gewährleisten (siehe Dokumentation der jeweiligen Fachmodule).

Mögliche Fehlermeldungen:

Javascript muss im Browser aktiviert sein um GAIA-MV professional nutzen zu können.

In den Browsern kann hierfür eine niedrigere Sicherheitsstufe für vertrauenswürdige Sites verwendet werden (siehe nächste Kapitel).


Microsoft Internet Explorer (IE)

GAIA-MVprofessional Handbuch

Einleitung

Sicherheitseinstellungen - Microsoft Internet Explorer (IE)

1. Schritt: Hinzufügen der notwendigen Internetadresse

Extras - Internetoptionen - Reiter „Datenschutz“.

Mit der Schaltfläche „Sites“ die Liste der vertrauten Webseiten öffnen. Gewünschte Webadresse eingeben und „Zulassen“.

Tipp: Hierbei lassen sich auch Wildcards (Joker) verwenden (z.B. *.gaia-mv.de).

2. Schritt: Sicherheitsstufe zurücksetzen

Unter „Einstellungen“ wird weiterhin die zugehörige Sicherheitsstufe angezeigt. Eventuell ist es hier notwendig, auf die „Standardstufe“ oder eine niedrigere Stufe umzustellen.

Normalerweise werden die nötigen Zusatzfenster (Abfragen etc.) auch mit der Einstellung Popupblocker einschalten geöffnet. Sollte dies nicht funktionieren, kann unter Ausnahmen die Internetseite zur Freigabe eingetragen werden.

Kontaktieren Sie gegebenenfalls Ihren System-Administrator.


Mozilla Firefox

GAIA-MVprofessional Handbuch

Einleitung

Sicherheitseinstellungen - Mozilla Firefox

Normalerweise werden die nötigen Zusatzfenster (Abfragen etc.) auch mit der Einstellung Pop-up-Fenster blockieren geöffnet. Sollte dies nicht funktionieren, kann unter Ausnahmen die Internetseite zur Freigabe eingetragen werden.


Basistechnologien

Basistechnologien

Basistechnologien

Serverseitig wird als Mapserver der UMN-Mapserver eingesetzt. Insgesamt stellt er eine bemerkenswerte Entwicklung der Open-Source-Community dar, welche die wesentlichen Aspekte der traditionellen Präsentation raumbezogener Informationen abdeckt. Die Funktionalität dieser Lösung und ihre universelle Einsetzbarkeit, verbunden mit der Möglichkeit, das verfügbare Budget fast ausschließlich für die eigentliche Applikationsentwicklung zu verwenden, machen dieses Projekt zu einem wertvollen Element der Vermittlung raumbezogener Informationen im Intranet/Internet.

Der UMN-Mapserver unterstützt das klassische Modell, die Grafik und die Webseite werden auf dem Server dynamisch generiert und als HTML-Seite an den Client gesendet. Die HTML-Seiten können durch den Anwendungsentwickler mit JavaScript angereichert werden. Geodaten können datei- oder datenbankorientiert abgelegt und eingebunden werden. Als Datenformate werden das weit verbreitete Shapefile-Format der Firma ESRI, sowie diverse Rastergrafik-Formate und Geodatenbanken unterstützt. Hervorzuheben sind die Unterstützung von Bibliotheken (wie OGR und GDAL) oder der Einsatz von Datenbanken (z.B. PostgreSQL/PostGIS) zur Verwaltung großer Vektor- und Rasterdatenbestände.

Die Anwendung wird serverseitig über einen mapserverspezifischen Präprozessor angesprochen. Der UMN-Mapserver liegt - neben einer Quelltextversion - in Varianten für verschiedene Unixderivate (u.a. Linux) sowie für diverse Microsoft-Betriebssysteme vor. Die Einbindung und Darstellung der Geodaten wird in einer sogenannten Map-Konfigurationsdatei festgelegt. Der Präprozessor erzeugt mit Hilfe des Mapservers GIF-, PNG- oder JPEG-Grafiken und transportiert diese gemeinsam mit HTML-Fragmenten in den Browser des Clients. Die Grafiken sind je nach Bildgröße und Inhalt nur einige Kilobyte groß. Der UMN-Mapserver kann sowohl auf Basis des Apache-Web-Servers als auch auf anderen Webservern betrieben werden.

Zur Verwaltung der Nutzer wird standardmäßig die Datenbank PostgreSQL eingesetzt. Eine Einbindung anderer Datenbanken ist auf Anfrage ebenfalls möglich.

Serverseitig wird die Entwicklungsumgebung PHP und die speziell für den Mapserver entwickelte Bibliothek PHP-Mapscript verwendet.

Auf Basis oben beschriebener Technologien wurde in der Datenverarbeitungszentrum Mecklenburg-Vorpommern GmbH GAIA-MVprofessional entwickelt. Clientseitig wird für die Gruppe der „Viewer“ nur ein Webbrowser benötigt. Die Applikation GAIA-MVprofessional des DVZ M-V ermöglicht dem Nutzer, die Geodaten auf komfortable Weise zu benutzen. Sie wird beim ersten Aufruf der Applikation in Form von JavaScript in den Browser des Clients vom Server heruntergeladen. Aus Gründen der Sicherheit werden keine Plug-Ins, Java-Applets und ActiveX-Controls verwendet. In den folgenden Abschnitten wird der Funktionsumfang von GAIA-MVprofessional beschrieben.


Registrierung

Registrierung und Anmeldung

Registrierung

Es gibt öffentliche und passwortgeschützte Profile (Fachsichten). Letztere erfordern eine Registrierung des Nutzers im System bzw. eine Freischaltung durch dem Administrator. Dem registrierten und angemeldeten Nutzer stehen auch bei der Nutzung eines öffentlichen Profils über den Standard hinaus erweiterte Möglichkeiten zur Verfügung. Somit wird unter Anderem das nutzerspezifische Abspeichern gewährleistet für Themenbäume, Digitalisier-, Editier- und Attributierungsumgebung sowie der allgemeinen Systemeinstellungen.


Anmeldung

Registrierung und Anmeldung

Anmeldung

Je nach Konfiguration wird zwischen öffentlich zugänglichem und anmeldungspflichtigem Aufruf unterschieden. In geschützten Profilen meldet sich der Nutzer am System mit seinem Nutzernamen und Passwort an.

Nach der serverseitigen Prüfung der eingegebenen Daten bzw. nach dem Klick auf ein öffentliches Profil erscheint auf dem Bildschirm die Applikation GAIA-MVprofessional.

Eine Anmeldung ist auch im Nachhinein aus einem öffentlichen Profil möglich. (siehe Abb.). Existieren mehrere Profile, ist ein Wechsel zwischen den verschiedenen Profilen aus der Anwendung heraus ebenfalls möglich. Im oberen Titelfenster ist hierfür die Verlinkung „Anmelden“ zu finden:

Aus Sicherheitsgrunden ist es wichtig, sich auch von GAIA wieder abzumelden bzw. der Browser zu schließen. Angemeldeten Benutzern steht einen Link „Abmelden“ im Titelfenster zur Verfügung.


Bildschirmaufteilung

Anwendungsaufbau

Bildschirmaufteilung

Das Produkt zeichnet sich durch eine vierteilige Bildschirmaufteilung aus.

Sie besteht aus:

· einem Titelfenster , reserviert für Logo, Werbebanner, Links, An- und Abmeldung o.ä.,
· einem Referenzkarten- und Legendefenster ,
· einem Hauptkarten- und -bearbeitungsfenster und
· einem Applikationsbereich zur Themensteuerung , zur räumlichen Vorauswahl und zur Stellung von Suchabfragen .

Das Fenster mit dem Logo, das Übersichtskartenfenster und der Applikationsbereich können bei Bedarf über Schaltflächen am oberen rechten Fensterrand ausgeblendet werden. Die Schaltfläche zum Wiedereinblenden befindet sich in der oberen linken Ecke des Hauptkartenfensters.

Die Möglichkeit des Ausblendens ist sinnvoll, um im Bedarfsfall einen größeren Kartenausschnitt zu erhalten.

Wird nach dem Ausblenden oder Wiedereinblenden das Hauptkartenfenster mit der Maus überfahren, passt sich der Kartenausschnitt in seiner Größe an den zur Verfügung stehenden Raum automatisch an. Ein Vergrößern und Verkleinern des gesamten Browserfensters bewirkt ebenfalls eine automatische Anpassung des Kartenausschnittes an die Größe des Karten- und Bearbeitungsfensters.

Ein Vergrößern des Browserfensters kann bei einer langsamen Netzverbindung allerdings auch eine längere Bildladezeit nach sich ziehen, da die zu übertragende Datenmenge wächst!

Zusätzlich zur vierteiligen Bildschirmaufteilung können je nach ausgeführter Funktion weitere Dialogfenster (z.B. als Ergebnis einer Suche oder Abfrage) auf dem Bildschirm erscheinen.


Titel

Anwendungsaufbau

Titel

Im Titelbild sind das GAIA-Logo sowie Platzhalter für diverse Werbebanner oder andere Logos zu finden. Das Fenster kann mit einem Klick auf den Schriftzug "Titel ausblenden" ausgeschaltet werden.

So kann auf dem Bildschirm mehr Platz für die Kartendarstellung gewonnen werden. Noch mehr Platz erhält man durch Drücken der F11-Taste.

Ebenso enthält die Titelleiste je nachdem, ob es sich um einen nicht registrierten oder registrierten Nutzer handelt, verschiedene Links.

Der nicht registrierte Nutzer findet neben dem Link zur Beendigung der Sitzung einen Link zur Anmeldung/Registrierung.

Der registrierte und angemeldete Nutzer findet neben dem Link zur Beendigung der Sitzung zusätzlich einen Link zur Speicherung der vom Nutzer vorgenommenen Einstellungen.


Referenzkarte und Legende

Anwendungsaufbau

Referenzkarte und Legende

Die Karteikarte Referenzkarte enthält eine Übersichtskarte. In der Referenzkarte ist der aktuelle Kartenausschnitt des Karten- und Bearbeitungsfensters mit einem roten Rahmen gekennzeichnet. Die Karteikarte Legende enthält die aktuelle Kartenlegende als Grafik.

Mit dem Icon [image] in der linken oberen Ecke kann dieses Fenster ausgeblendet werden, um ein größeres Hauptkartenfenster zu ermöglichen.


Referenzkarte

Anwendungsaufbau

Referenzkarte

Die Karteikarte enthält eine Übersichtskarte. In der Referenzkarte ist der aktuelle Kartenausschnitt des Karten- und Bearbeitungsfensters mit einem roten Rahmen gekennzeichnet.

Mit einem Mausklick in die Referenzkarte kann der Kartenausschnitt des Karten- und Bearbeitungsfensters unter Beibehaltung des Maßstabes gewechselt werden. Umgekehrt werden Änderungen im Hauptkartenfenster durch eine Änderung der Größe und der Lage des roten Rahmens in der Referenzkarte angezeigt.

Das Einzeichnen des aktuellen Kartenausschnittes erfolgt auf dem Client. Die Übersichtskarte muss also nicht erneut geladen werden. Deshalb können in die Applikation durchaus anspruchsvollere Übersichtskarten eingebunden werden.

Es besteht zusätzlich die Möglichkeit, das aktuelle Hauptkartenfenster zur Referenzkarte zu erklären. Die Schaltfläche „Neue Übersichtskarte“ [image] befindet sich im Hauptkartenfenster. Durch Aktivierung dieser Schaltfläche wird der aktuelle Kartenausschnitt zur temporären Referenzkarte. Das Wechseln der Übersichtskarte ist sinnvoll, wenn der Nutzer z.B. längere Zeit in einem eng begrenzten Gebiet arbeitet.

Dies führt zu einer besseren Übersicht, wenn der Nutzer sich z.B. nur innerhalb eines Stadtgebietes bewegt und er das gesamte Stadtgebiet als neue Referenzkarte benutzt. Der aktuelle Kartenausschnitt wird dabei weiterhin als rotes Rechteck in der neuen Referenzkarte dargestellt und erleichtert somit die Navigation.


Legende

Anwendungsaufbau

Legende

Die Karteikarte Legende enthält die aktuelle Kartenlegende als Grafik.

Mit einem Klick auf der Legendengrafik wird sie in einem neuen Fenster geöffnet. Besonderes bei längeren und komplizierten Legenden kann dies hilfreich sein.

Die Legenden fremder WMS-Dienste werden im Legendenfenster bei einem Klick auf das Themensymbol eingeblendet.

Im Druck werden die Legenden fremder WMS-Dienste als normale Zeichenobjekte (Bilder) eingefügt und können so auch verschoben oder entfernt werden. Analog der Legenden der topographischen Karten.


Hauptkarte

Anwendungsaufbau

Hauptkarte

Das Hauptkartenfenster ist der Hauptbestandteil von GAIA-MVprofessional. Hier werden alle Karten und sonstigen Bilder, welche der Mapserver erzeugt, dargestellt.

Das Karten- und Bearbeitungsfenster ist mit Hilfe des Karteikartenprinzips gegliedert.

Je nachdem, welche Karteikarte seitens des Nutzers aktiviert wurde, stehen neben den Möglichkeiten der dynamischen Navigation zusätzliche Funktionalitäten (Abfragen, Messen & Zeichnen, Drucken, Extras) zur Verfügung.

In der Karteikarte „Einstellungen“ kann der Nutzer voreingestellte Einstellungen ändern.

Mit dem Icon [image] in der linken oberen Ecke des Hauptkartenfensters können Referenzkarte und Themenbaum/Suche wieder eingeblendet werden, wenn sie vorher ausgeblendet wurden.


Themenbaum und Suche

Anwendungsaufbau

Themenbaum und Suche

Mit Hilfe des Themenbaumes werden die eingebundenen Themen (Geodaten) gesteuert. Mit der Suche kann der Nutzer diverse Themen abfragen oder gleich zu bestimmten Koordinaten springen.

Mit dem Icon [image] in der linken oberen Ecke kann dieses Fenster ausgeblendet werden, um ein größeres Hauptkartenfenster zu ermöglichen.


Themensteuerung

Themen

Themensteuerung

Mit Hilfe der Karteikarte Themen lassen sich Sichtbarkeit und Abfragbarkeit der eingebundenen Themen steuern sowie Legenden und evtl. eingebundene Metadaten anzeigen. Themen können hinzugefügt, umbenannt, verschoben oder entfernt werden.

Sichtbarkeit: Die quadratischen Schaltflächen [image] steuern die Anzeige der Themen im Hauptkartenfenster. Ein graues Häkchen [image] bedeutet, dass ein Thema im aktuellen Maßstab nicht angezeigt werden kann. Fährt der Nutzer mit der Maus über den Themennamen, wird der Maßstabsbereich des Themas angezeigt. Änderungen im Themenbaum müssen mit der Schaltfläche "Karte aktualisieren" bestätigt oder durch ein Zoom bzw. Pan im Hauptkartenfenster ausgelöst werden.

Abfragbarkeit: Wurde keine runde Schaltfläche [image] aktiviert, werden alle gerade sichtbaren Themen abgefragt. Im Themenbaum signalisieren vorhandene bzw. nicht vorhandene runde Schaltflächen, ob ein Thema abfragbar ist oder nicht. Mit der Aktivierung der runden Schaltknöpfe kann die Abfragbarkeit von Themen eingeschränkt werden.

Metadaten: Eventuell vorhandene Metadaten sind mit einem [image] hinter der Layer- bzw. Gruppenbezeichnung gekennzeichnet. Beim Klick auf dieses [image] werden die Metadaten (z. B. Copyright-Vermerke oder Ansprechpartner) in einem separaten Fenster angezeigt.


Steuerung der Sichtbarkeit

Themen

Steuerung der Sichtbarkeit

Die Farbgebung des Häkchens im Schaltknopf signalisiert, ob ein Thema nach dem Zuschalten dargestellt wird oder nicht. Ein schwarzes Häkchen bedeutet, das Thema ist bei dem aktuellen Maßstab des Kartenausschnittes im Hauptkartenfenster darstellbar, ein graues Häkchen deutet hingegen darauf hin, dass dieses Thema bei dem aktuellen Maßstab trotz Anforderung nicht gezeichnet werden kann. Erst eine Maßstabsänderung des Kartenausschnittes durch den Nutzer (Vergrößern/Verkleinern) bewirkt die Anzeige des Themas im Hauptkartenfenster.

Zum Aktualisieren des Karteninhalts im Hauptkartenfenster muss die Schaltfläche "Karte aktualisieren" im unteren Teil des Themenbaums betätigt werden. Dabei erfolgt auch ein Abgleich mit dem Themenbaum.

Fährt der Nutzer mit der Maus über den Themennamen, erscheint im Browser ein kleines Fenster (Tooltip). In diesem Fenster wird das Maßstabsintervall angezeigt, in dem das jeweilige Thema gezeichnet wird.


Steuerung der Abfragbarkeit

Themen

Steuerung der Abfragbarkeit

Im Themenbaum signalisieren vorhandene bzw. nicht vorhandene runde Schaltflächen, ob ein Thema abfragbar ist oder nicht.

Grundsätzlich gilt: Wurde keine runde Schaltfläche aktiviert (alle aus) und es wird eine Abfrage im Hauptkartenfenster (z.B. mit Hilfe eines Polygons) durchgeführt, werden alle gerade sichtbaren Themen (mit schwarzem Häkchen) abgefragt. Dies ist mitunter erwünscht, die Ergebnisliste kann dadurch aber sehr lang und unübersichtlich werden.

Mithilfe der Aktivierung der runden Schaltknöpfe kann die Abfragbarkeit von Themen eingeschränkt werden.

Das heißt, werden runde Schaltknöpfe aktiviert, bezieht sich eine Abfrage nur auf diese Themen. Voraussetzung für den Erfolg ist, dass sich diese Themen gerade im sichtbaren Maßstabsbereich befinden (schwarzes Häkchen).


Generallegende und Metainformationen

Themen

Generallegende und Metainformationen

Die Anzeige der Legenden der einzelnen Layer ist im Themenbaum integriert. Zum Anzeigen der Legende eines bestimmten Layers muss auf das kleine Bildchen links neben dem jeweiligen Layernamen geklickt werden. Die Legende wird in die Karteikarte Legende gezeigt.

Die Legende erscheint nur, wenn der Layer (bzw. die Inhalte des Layers) auch im Hauptkartenfenster zu sehen ist, d. h. der Layer aktiviert ist und im aktuellen Maßstab auch angezeigt werden kann.

Je nach der Art und Weise, wie die Themen eingebunden wurden, erscheinen einfache, dynamisch generierte oder anspruchsvolle, vorbereitete Legenden.

Bei den Rasterdaten der Topographischen Karten wird die Zeichenerklärung der analogen Ausgabe angezeigt, wieder in Abhängigkeit des Maßstabes, bzw. welche Topographische Karte gerade sichtbar ist. Einige Layer besitzen auch keine eigene Legende. In diesem Falle wird die Legende der Gruppe eingeblendet.

Sind Metadaten vorhanden und eingebunden (z.B. Copyright-Vermerke oder Ansprechpartner), so kann der Nutzer diese durch einen Mausklick auf die Infoschaltfläche (Icon folgend auf die Themenbezeichnung) einsehen.


Themenbaumausgestaltung

Themen

Themenbaumausgestaltung

Mit Hilfe der rechten Maustaste (auf den Themennamen) können Themen über ein Menü umbenannt oder gelöscht werden oder neue Gruppen hinzugefügt werden. Des Weiteren können die Themen, ebenfalls mit gehaltener linker Maustaste, innerhalb des Themenbaumes verschoben werden.

Vorgenommene Änderungen am Themenbaum können durch Betätigung des Knopfes „Themenbaum rücksetzen auf Sessionbeginn“ rückgängig gemacht werden:

Angemeldete Nutzer haben die Möglichkeit, den geänderten Themenbaum zu speichern, der bei der nächsten Anmeldung dann beim Start des Systems nutzerspezifisch geladen wird. Dies gilt auch für über den Themenmanager selbst hinzugefügte WMS-Layer.

Außerdem können angemeldete Nutzer den Themenbaum auf die Werkseinstellung zurücksetzen. Hierbei werden alle durch den Nutzer durchgeführten Änderungen unwiderruflich gelöscht.


Themenmanager

Themen

Themenmanager

Standardmäßig ist im Basissystem GAIA-MVprofessional ein durch den Betreiber des Systems oder eine Fachanwendung definierter Umfang an Themen integriert, welche sofort nach dem Start des Systems im Themenbaum aufgelistet sind. Diese Begrenzung ist sinnvoll, um den Themenbaum nicht endlos lang werden zu lassen und die Übersichtlichkeit zu gewährleisten. Mit Hilfe des Knopfes „Themen hinzufügen“ (oben und unten im Themenbaum) kann der Themenmanager gestartet werden.

Der Themenmanager ermöglicht das Bearbeiten und Erstellen eines individuellen Themenbaumes, u.a. das Hinzufügen von verfügbaren Themen (Layern), für die der Nutzer berechtigt ist. Er wird in einem separaten Fenster geöffnet.

Unter „Verfügbare Themen (Quelle)“ findet der Nutzer alle „öffentlichen“ Themen, bzw. für die er zusätzlich berechtigt ist. Rechts unter „Ihre genutzten Themen (Ziel)“ wird zunächst der Standardthemenbaum angezeigt, der mit Hilfe der angebotenen Schaltflächen bearbeitet werden kann. Mit Hilfe der entsprechenden Schaltflächen können alle verfügbaren Themen übernommen oder einzelne Themen per „drag and drop“ in den Themenbaum eingefügt werden. Weiterhin lassen sich im Zielthemenbaum mit Hilfe der linken oder rechten Maustaste Themen innerhalb des Zielthemenbaumes verschieben, umbenennen, löschen oder neue Themenüberschriften hinzufügen.

Vorgenommene Änderungen am Zielthemenbaum können durch Betätigung der Schaltfläche „Eigene Themen zurücksetzen“ rückgängig gemacht werden.

Erst nach Betätigung der Schaltfläche „Übernehmen“ wird der Zielthemenbaum in GAIA übernommen. Nach dem Schließen des Themenmanagers kann nun der aktualisierte Themenbaum genutzt werden.

Der „manipulierte“ Themenbaum bleibt für den Zeitraum der Session erhalten. Angemeldete Nutzer haben zusätzlich die Möglichkeit, den individuell angepassten Themenbaum zu speichern. Dieser wird bei der nächsten Anmeldung dann beim Start des Systems nutzerspezifisch geladen.

oder


WMS-Dienste

Themen

WMS-Dienste

Die Schaltfläche „WMS-Dienst laden“ ist im Themenmanager integriert und ermöglicht die Einbindung weiterer WMS (Web Map Services - webbasierte Kartendienste):

Beim Klick auf diese Schaltfläche erscheint der folgende Dialog:

Hier können Sie eine gültige Adresse für einen WMS-Dienst eingeben und den Dienst in GAIA-MV einfügen.

Unterstützt werden auch Dienste, bei denen die Zugriffsberechtigung mittels Benutzername und Passwort nachgewiesen wird. Hierzu sind die jeweiligen Felder auszufüllen. Bei freien, ungeschützten WMS-Diensten können diese Felder unberücksichtigt bleiben.Nach dem Betätigen des Knopfes „WMS Dienst laden“ wird der Dienst mit allen Layern angezeigt.

Sollte es zu Fehlern kommen, werden diese direkt angezeigt.

Die Styles der Layer sind anwählbar, wenn mindestens 2 Auswahlmöglichkeiten im GetCapabilies Dokument vorhanden sind.

Nach dem Betätigen des Knopfes „Übernehmen" wird der Dienst mit allen Layern in den Zielthemenbaum im Themenmanager übernommen.

Eine endgültige Übernahme in den GAIA-Themenbaum erfolgt erst, wenn im Themenmanager die entsprechenden Schaltknöpfe für Abbrechen bzw. Übernehmen betätigt werden.

Sofern ein Style ausgewählt wurde, ist dieser im Layernamen ersichtlich.
Beim Überstreichen der Layer erscheint der Layername.

Hinweis: Maßstabsangaben sind ca. Werte und hängen von Annahmen (dpi-Wert) ab, die sich unterscheiden können.

Weitere Informationen zur Darstellung und Druck der Layerausgestaltung finden Sie im Kapitel Legenden .


Ladezeiten von Themen (Performance)

Themen

Ladezeiten von Themen (Performance)

In der Applikation werden für den Aufbau der Karte oft viele Daten aus verschiedenen Themen abgefragt. Dabei können auch WMS-Dienste enthalten sein, wo die Daten von entfernten Servern angefordert werden. Dies kann unter Umständen zu erhöhten Erzeugungszeiten bei der Kartenerstellung führen. Um eine adäquate Performance sicher zu stellen, sollten „langsame“ Themen beim Navigieren deaktiviert und erst anschließend aktiviert werden. Im oberen Bereich des Themenbaumes befindet sich ein „Zeit mess“-Button. Dieser lädt die Karte wie „Karte aktualisieren“ neu und gibt ein zusätzliches Informationsfenster aus.

Dabei handelt es sich um die Zeiten, die der GAIA-Server benötigt, um ein Thema in die Karte einzubinden. Sobald ein angefordertes Thema kein Ergebnis zurück meldet bzw. eine gewisse Ladezeit überschreitet, erscheint ein zusätzlicher Fehlerhinweis.

Sollte die Karte aufgrund „schlechter“ Daten nicht erstellt werden können, erscheint folgendes Fehlerfenster in der Karte. Mit einem Klick auf den Link „hier“ wird die Anwendung neu gestartet.

Unter Umständen kann die Performance durch die Reduzierung von aktiven Themen verbessert werden. Sollten zu viele Themen eingeschaltet sein, erscheint auch hierfür ein Warnhinweis im Kartenfenster.


Objektbaum

Themen

Objektbaum

Der Objektbaum ist eine neue Möglichkeit Objekte innerhalb von GAIA-MVprofessional nach bestimmten Kriterien (z.B. administrative Zugehörigkeiten von Altlasten, Bergbauberechtigungen, Breitbandaktivitäten des Landes) hierarchisch abzubilden und zu suchen. Die Kriterien müssen nicht räumlicher Natur sein. Anwender rein klassischer alphanumerischer Anwendungen, können über diese Ordnungsstrukturen i.d.R. schneller die gesuchten Informationen finden als über die Karte. Objektbäume sind oft Bestandteil von unter GAIA entwickelten Fachanwendungen.


Koordinatenanzeige

Koordinatenanzeige

Koordinatenanzeige

Bei allen Grundfunktionen wie Navigation , Abfrage , Messen und Zeichnen laufen beim Ziehen der Maus unten rechts im Kartenfenster die Koordinaten mit Angabe der aktuellen kartografischen Abbildung mit. Die Koordinate bezeichnet die jeweils aktuelle Mausposition.

Das System für die Koordinatenanzeige kann über den Reiter Extras unter der Schaltfläche Einstellungen , durch Klick auf Karteneinheiten und Kartenprojektion vom Nutzer ausgewählt werden. Zusätzlich besteht die Möglichkeit, eine andere Kartenprojektion zu wählen. Koordinatenanzeige und Kartenprojektion müssen nicht das gleiche Referenzsystem sein, die Koordinaten werden bei Bedarf umgerechnet. Eine Voreinstellung seitens des Geoadministrators ist möglich. Das grundsätzliche „Mitlaufen“ der Koordinaten kann in der Einstellungen vom Nutzer abgeschaltet werden. Letzteres ist mitunter in einer Terminalumgebung (Citrix, Websphere) notwendig, um ein Bildschirmflimmern zu unterdrücken.

Die Koordinaten (Stützpunkte der Flächenumringe und Linien, Kreismittelpunkt, Einzelpunktlage), von gezeichneten Objekten können automatisch nach Aktivierung in eine Zwischenablage übernommen werden. Siehe dazu die Dokumentation zur Zwischenablage der Koordinaten .

Die Koordinaten werden bei einem Systemübergang (Bessel (RD/83) ßà ETRS89 ßà Krassowski (S42/83)) mithilfe der 7 Parameter Transformation umgerechnet. Für das gesamte Gebiet kann aber nur ein Parametersatz pro Systemübergang vom Programmsystem derzeit berücksichtigt werden. Genauere Parametersätze für einzelne räumliche Einheiten stehen nicht öffentlich zur Verfügung.

Die Abweichungen beim Umrechnen zwischen den verschiedenen Systemen mit Hilfe von einem Parametersatz liegen so z.B. für Mecklenburg-Vorpommern bei 2 dm bis maximal 2 Meter. Demnach kann nicht von einer geodätischen Genauigkeit gesprochen werden (Genauigkeit im Millimeterbereich, 3 Stellen nach dem Komma).

Hinzu kommt die Unschärfe durch die Bildschirmauflösung (i.d.R. 72 dpi), Kissenverzerrungen u.ä. Aus obigen Gründen werden die Koordinaten auch nur ohne Kommastellen gelistet. Trotzdem ist für viele Nutzer diese Genauigkeit für die Geocodierung völlig ausreichend.

Koordinatentransformationen mit geodätischer Genauigkeit bleiben somit den Kataster- und Vermessungsbehörden vorbehalten, diese sind damit der Ansprechpartner für Transformationen mit hoher Genauigkeit.


Suche

Suche

Suche

Die Karteikarte „Suche“ ist dreigeteilt und befindet sich unter dem Reiter „Suche“ neben dem Themenbaum.

Im oberen Teil enthält sie Möglichkeiten zur räumlichen Suche durch Texteingaben. Im mittleren Teil wird die räumliche Begrenzung, auf die sich die Suche bezieht, in Form von Koordinaten angezeigt. Im unteren Teil ist eine Suche mit Hilfe von Koordinaten möglich.

Der Nutzer wählt das Thema aus einer Liste und gibt anschließend in ein Suchfeld eine Mindestanzahl von Buchstaben oder Zahlen ein. Der Nutzer muss z.B. nicht den vollständigen Orts- oder Gemeindenamen eingeben! Auch wird nicht zwischen Groß- und Kleinschreibung unterschieden.
Für die Suche nach Zeichenketten können auch Platzhalter (Joker) eingesetzt werden: ? steht für ein Zeichen, * für beliebig viele Zeichen. "b?rg" gleicht demnach beide "berg" und "burg", aber auch "barg", "borg", usw. und "w*r" gleicht sowohl "wismar" als auch "war".
Werden die vorhergehenden Sonderzeichen selbst gesucht, ist ihnen in der Eingabe ein Backslash voranzustellen (\* und *\?).
Dies kann sehr hilfreich sein bei Unklarheit hinsichtlich der Rechtschreibung des geografischen Namens und spart Zeit.

Mitunter möchte der Nutzer aber nur die Ergebnisse, die den Suchbegriff exakt als ganzes Wort enthalten (präzisierte Suche). Hierzu muss der Suchbegriff in Anführungszeichen gesetzt werden. Diese präzisierte Suche funktioniert analog der Suche im Geoportal und mindert bei Bedarf die Zahl der gefundenen Ergebnisse.

Werden mehrere Lösungen gefunden (z.B. bei der Eingabe von „berg“ bei der Ortssuche), werden diese als Liste in einem neuen Fenster angezeigt. Der Nutzer braucht jetzt nur noch auf die Lupe der richtigen Zeile klicken und schon erscheint im Hauptkartenfenster der gewünschte Ausschnitt mit der gewünschten Lokalität im Zentrum.

Je nach Thema wird die gefundene Lokalität hervorgehoben oder beschriftet.

Die Markierungen und Beschriftungen der Lokalitäten bleiben auch bei einem Zoom bzw. Pan solange erhalten, bis der Nutzer diese Beschriftungen im Hauptkartenfenster wieder löscht.

Die Suche kann durch Betätigen der Schalter „global“ oder „lokal“ räumlich eingeschränkt werden.

Global bedeutet, dass der Server im kompletten Datenbestand des angewählten Themas sucht. Dadurch kann mitunter eine sehr lange Liste entstehen (z.B. bei der Such nach Orten (Adressen) mit der Silbe „berg“): in diesem Fall wird die Ergebnisliste eventuell gekürzt.

Lokal bedeutet hingegen, dass der Server seine Suche auf den Bereich des aktuellen Kartenausschnittes des Hauptkartenfensters beschränkt. Beim Umschalten auf „lokal“ erscheinen in der Koordinatenanzeige die den aktuellen Kartenausschnitt begrenzenden Koordinaten.

Bei der Suche von Lokalitäten über Koordinaten kann sich der Nutzer entscheiden, ob der Punkt in der Karte markiert und/oder beschriftet werden soll. Hier wird auch die Eingabe geographischer Koordinaten in Grad/Min/Sek unterstützt.


Navigation

Navigation

Navigation

Die Karteikarte „Navigation“ enthält eine Vielzahl von Möglichkeiten der Navigation. Bei den Werkzeugen der Navigation (und auch bei den anderen) gibt es zwei Arten von Schaltflächen. Die eine Gruppe löst beim Klick auf sie einen Vorgang aus. Die zweite Gruppe wird mit einem Klick aktiviert und die "eingedrückte" Schaltfläche zeigt einen aktiven Modus an.

Allgemeine Icons (auch bei Abfrage, Messen und Zeichnen):
Vergrößern der Karte durch Aufziehen einer Box mit gedrückter linker Maustaste.
Verkleinern durch Klick in die Karte: Klickpunkt wird zum neuen Kartenmittelpunkt.
Verschieben (Pan) der Karte mit gedrückter linker Maustaste.
Neuen Kartenmittelpunkt setzen (zentrieren): Klickpunkt wird zum neuen Kartenmittelpunkt.

Diese vier Funktionen werden, da sie eine Interaktion des Nutzers in der Karte erfordern, der dynamischen Navigation zugeordnet. Diese Funktionen sind auch in den anderen Karteikarten des Karten- und Bearbeitungsfensters enthalten.

Statische Navigationsfunktion stehen dem Nutzer im Navigationsmodus zur Verfügung.

Navigationsmodusspezifische Icons:
Vergrößern unter Beibehaltung des Mittelpunktes.
Verkleinern unter Beibehaltung des Mittelpunktes.
Vorhergehenden Kartenausschnitt anzeigen.
Nachfolgenden Kartenausschnitt anzeigen.
Feste Zoomstufen, jeder Balken repräsentiert einen anderen vom Systemadministrator vordefinierten Maßstab, z.B. 1:1000, 1:10000, usw.
Neustart von GAIA-MV (Anfangskarte mit aktuellen Themenbaum einstellungen).
Aktuellen Kartenausschnitt als Referenzkarte übernehmen.
Zum gewünschten Maßstab wechseln (Maßstab eingeben und auf „go“ klicken).

Das Verkleinern und Vergrößern erfolgt mittels eines Zoomfaktors. Dieser ist durch den Nutzer in den Einstellungen wählbar. Je größer der Zoomfaktor, desto schneller kann herein- bzw. herausgezoomt werden. Der Klickpunkt wird neuer Kartenmittelpunkt.

Außerdem können mit Zeichenobjekte löschen alle Zeichenelemente und Abfrageergebnisse aus der Karte gelöscht werden.

Barrierefreie Navigationsfunktionen stehen dem Nutzer in allen Modi zur Verfügung. Einzige Voraussetzung ist ein aktives Hauptkartenfenster. D.h. der Fokus des Cursors muss innerhalb der Karte (nicht im Themenbaum, Suchfenster, Abfrageergebnis...) liegen.

Navigation mit der Tastatur:

Pfeiltasten (links/ rechts/ oben/ unten) - Verschiebt den Ausschnitt in die gewünschte Richtung - jeweils einen halben Kartenausschnitt.

Plus-Taste (Ziffernblock): Vergrößern der Karte um den konfigurierten Zoomfaktor*

Minus-Taste (Ziffernblock): Verkleinern der Karte um den konfigurierten Zoomfaktor*

Navigation mit der Maus:

Mausrad auf: Vergrößern der Karte um den konfigurierten Zoomfaktor*

Mausrad ab: Verkleinern der Karte um den konfigurierten Zoomfaktor*

* Standardeinstellung 2x, frei konfigurierbar (siehe Kapitel Einstellungen -> Karteneinheiten und Kartenprojektion)


Abfragearten

Abfragen

Abfragearten

Die Datenstruktur eines GIS ist so aufgebaut, dass sowohl geometrische als auch thematische Angaben in tabellarischer Form vorhanden und verknüpft sind. Durch Abfragen können somit Fragestellungen zu sachlichen und räumlichen Kriterien gelöst werden. Die Selektion der Ergebnisse wird dabei in der Karte angezeigt.

Die thematischen Abfragen werden entweder mit SQL (Structured Query Language) oder systeminternen Abfragesprachen ausgeführt, wobei logische Ausdrücke wie und, oder, nicht, größer als etc. zum Einsatz kommen. Durch Verknüpfungen und verschachtelten Ausdrücken lassen sich mehrere Themen miteinander kombinieren und somit komplexe Abfragen generieren.

Zusätzlich profitiert der Anwender von den Analysefunktionen eines GIS, die auf räumlichen (geometrischen oder topologischen) Selektionskriterien basieren. In Vektormodellen ist der Punkt die kleinste geometrische Einheit. Alle höheren Strukturen wie Polylinien bauen auf Punkten auf, wobei ein geschlossener Linienzug eine Fläche (Polygon) darstellt. Ziel der räumlichen Abfragen ist es, geometrische Beziehungen zwischen Objekten eines oder mehrerer Themen zu ermitteln, um deren Lokalisierung zu erreichen.

Während thematische Abfragen Elemente bezüglich ihrer Eigenschaften identifizieren und räumliche Selektionskriterien Objekte anhand ihrer Lage auswählen, basieren die topologischen Suchkriterien auf der Anordnung der Objekte im Raum. Diese räumlichen Beziehungen besitzen Zugriffsmerkmale wie „benachbart“, „im Umkreis“, „Teil von“ oder „innerhalb“ und werden als Topologie bezeichnet.


Karteikarte Abfragen

Abfragen

Karteikarte "Abfragen"

Die Karteikarte „Abfragen“ enthält eine Reihe von Funktionen, um Geodaten räumlich und auch inhaltlich abfragen zu können. Die Symbole zur Abfrage sind durch ein "i" im Schaltknopf gekennzeichnet.

Hinter den vier Navigationsfunktionen stehen die Abfragefunktionen:
Abfrage per Punkt | Abfrage per Punkt.
Abfrage per Polylinie | Abfrage per Polyline.
Abfrage per Rechteck | Abfrage per Rechteck.
Abfrage per Polygon | Abfrage per Polygon.
Abfrage per Kreis | Abfrage per Kreis.
Abfrage aller selektierter Zeichenobjekte | Abfrage aller selektierter Zeichenobjekte.
Abfragemanager | Abfragemanager (Sachdaten abfragen).
 | Pufferdistanz um Abfragen per Punkt, Polylinie, Rechteck, Polygon und Kreis definieren. Einheiten sind auch einstellbar.
Änderungsmodus | Änderungsmodus (Zeichenobjekte verschieben, ändern und löschen).
Zeichenelemente löschen | Alle Zeichenelemente löschen.

Abfragen lassen sich ebenso miteinander kombinieren. Es können mit gedrückter Umschalt-/Shifttaste zuerst mehrere Punkte, Polylinien, Rechtecke, Polygone und/oder Kreise eingezeichnet werden. Abschließend wird die Abfrage über den Schaltknopf [image] gestartet. Somit ist auch eine Abfrage räumlich nicht benachbarter Objekte möglich.

Mit zuvor eingezeichneten und/oder hochgeladenen und dann ausgewählten Zeichenobjekten können ebenfalls über den Schaltknopf [image] Abfragen durchgeführt werden.

Die Steuerung, welche Themen gerade abfragbar sein sollen, kann der Nutzer im Fenster zum Themenbaum vornehmen. Wurden im Themenbaum keine Themen (eins oder mehrere) explizit ausgewählt, erfolgt die Abfrage über alle eingebundenen, gerade sichtbaren Themen.

Nach ausführen der Abfrage werden die Ergebnisse in einem neuen Fenster geöffnet.

Die Ergebnisse der Abfrage werden, wenn die Bildschirmabmessungen (Hardware) kleiner als 1024*768 Pixel sind, nicht mehr in einem separaten Fenster angezeigt, sondern über der Karte eingeblendet.

Schnellinfo

Die Karteikarte „Abfragen“ enthält in einigen GAIA-Versionen die optionale Abfragefunktion „Schnellinfo“. Der Blitz im Symbol symbolisiert den Begriff „Schnell“. Die Funktion wird, wie die anderen Abfragefunktionen auch, durch das Klicken auf das Symbol aktiviert. Die Abfrage selbst erfolgt durch das Klicken in der Karte auf das interessierende Objekt. Diese Funktion ist nur für spezielle Fachanwendungen verfügbar.

Im Unterschied zu den bisherigen Abfragefunktionen erscheint das Ergebnis der Abfrage nicht in einem separatem Fenster, sondern in einer Textblase über der Karte. Die Textblase passt sich in ihrer Lage automatisch dem Kartenausschnitt an und zeigt auf das gewählte Objekt. Der Kartenausschnitt bleibt also erhalten, wird nicht weggeschoben („Karte läuft nicht weg“) o.ä..

Was thematisch abgefragt wird, ist wie bei der normalen Abfrage über den Themenbaum steuerbar. Die Logik ist gleich. Wird explizit kein Thema im Themenbaum für die Abfrage aktiviert, werden die Themen der Zeichenreihenfolge nach abgefragt. Zuoberst gezeichnete Themen zuerst. Wurden Themen für die Abfrage aktiviert (runde Schaltknöpfe), werden diese und auch nur diese abgefragt. Geschlossen wird die Info entweder direkt durch das Klicken auf das Schließsymbol oben links in der Textblase oder indirekt durch Verschieben der Karte


Abfragemanager

Abfragen

Abfragemanager

Mit Hilfe des Abfragemanagers können Abfragen zu vorhandenen Sachdaten formuliert und durchgeführt werden.

Zuerst wird das zu abfragende Thema gewählt. Es werden dann Beispieldatensätze aus dem Thema gezeigt: hier kann der Nutzer die vorhandenen Felder und deren Werte einsehen, was zur Formulierung der Abfrage hilfreich ist.

Die Abfrage wird als logischer Ausdruck formuliert: Feldwerte aus der Datenbank werden mit vom Nutzer definierten Werten verglichen, und nur die treffenden Einträge als Ergebnis geliefert. Die Vergleichsfunktionen variieren nach Attributtyp:

Attributtyp | Funktion (Relation) | Kurzbeschreibung
Nummer (real bzw. integer) | = | gleich
 | < | kleiner
 | > | großer
 | <= | kleiner oder gleich
 | >= | großer oder gleich
 | <> | nicht gleich
Zeichenkette (string) | ist gleich | Zeichenkette ist genau gleich
 | ist in Liste | Attributwerte sind durch Komma von einander getrennt
 | enthält am Wortanfang | Attributwert enthält Zeichenkette am Anfang eines Wortes (z.B. "Neu" trifft "Neubrandenburg", "Neustadt Glewe", usw.)
 | enthält am Wortende | Attributwert enthält Zeichenkette am Ende eines Wortes (z.B. "burg" trifft "Neubrandenburg", "Dorf Mecklenburg", usw.)
 | enthält | Zeichenkette ist irgendwo im Attributwert enthalten (z.B. "ober" trifft "Bad Doberan")
 | enthält nicht | Zeichenkette ist nicht im Attributwert enthalten (z.B. "ost" trifft NICHT "Rostock")

Für die Suche nach Zeichenketten können auch Joker eingesetzt werden:

? steht für ein Zeichen,

* für beliebig viele Zeichen.

"b?rg" gleicht demnach beide "berg" und "burg", aber auch "barg", "borg", usw.

"w*r" gleicht sowohl "wismar" als auch "war".

Ob Platzhalter verwendet werden können oder nicht, kann der Nutzer einer Meldung oberhalb des Werteeingabefeldes entnehmen. Diese erscheint oder verschwindet nach der Feldauswahl.
Platzhalter können nicht nur bei der Suche in Zeichenkettenfeldern, sondern auch bei der Suche in Feldern vom Datentyp "int" in Verbindung mit dem Gleichheitsoperator (=) benutzt werden.
Werden die vorhergehenden Sonderzeichen selbst gesucht, ist ihnen in der Eingabe ein Backslash voranzustellen (\* und \?).

Wird der gesuchte Wortlaut in Anführungszeichen (einfache oder doppelte) gesetzt, erfolgt eine exakte Suche ohne Joker.

Wenn Feld (Spalte), Funktion (Relation) und Vergleichswert definiert sind, werden sie mit der Schaltfläche "Vergleichsausdrück übernehmen" zur Abfrage hinzugefügt bzw. mit der Schaltfläche „letzten Vergleichsausdruck ersetzen“ mit dem bereits bestehende Abfrageausdruck ersetzt. Es können mehrere Vergleichswerte mit logischen Operatoren (UND, ODER, NICHT) kombiniert werden, um komplexe Abfragen abbilden zu können.

Nachdem die gesamte Abfrage formuliert ist, wird die Datenbankabfrage mit der Schaltfläche "Ausführen" durchgeführt. Die Ergebnisse werden in einem neuen Fenster geöffnet.

Listenabfrage

Die Listenabfrage erfolgt mit Hilfe einer Datei. Zu einem Thema werden mehrer Werte abgefragt. Die Beispiele veranschaulichen dieses.


Abfrageergebnisse

Abfragen

Abfrageergebnisse

Abfrageergebnisse werden dem Nutzer themenbezogen präsentiert. Sie entstehen bei der räumlichen und thematischen Suche und bei der Nutzung der angebotenen Abfragefunktionen innerhalb des Hauptkartenfensters .

Das Erscheinungsbild der Abfrageergebnisse kann in Abhängigkeit von den abgefragten Themen und der Systemkonfiguration verschieden sein. Neben den allgemeinen Informationen können auch kleine Vorschaubilder von Fotos oder weiterführende Links in der Ergebnistabelle angezeigt werden.

Eine Änderung des Templates ist seitens des Geoadministrators möglich. Es können andere Klartextbezeichnungen („sprechende“ Feldnamen) für die Sachdatenfelder gewählt, nicht interessierende Felder in der Auflistung ausgeblendet, Felder aufsummiert (z.B. Flächen, Aggregationsfunktionen) werden, usw. Ebenso besteht die Möglichkeit Inselkartenwerke einzubinden und zu steuern sowie Download-Möglichkeiten bereitzustellen oder Fotos anzuzeigen.

Ergebnislisten können aber auch völlig eigenständige, aufwändig erstellte Applikationen sein. Diese Applikationen sind die grundlegenden Bestandteile von speziellen Fachschalen.

Die Ergebnisse einer Abfrage werden zeilenweise in einem neuen Fenster angezeigt und im Hauptkartenfenster bei Bedarf farblich markiert.

Beim Überfahren der Zeilen mit der Maus wird die aktuelle Position des Ergebnisses mittels einer animierten Grafik (Kreis), einer Linie oder einem stark vereinfachten Umring und einer Textblase hervorgehoben.

Welche Felder in der Textblase erscheinen, kann der Nutzer interaktiv durch Eindrücken der gewünschten Spalten beeinflussen.

Beim Klick auf die Zeile wird der Datensatz ausgewählt und die Markierung im Hauptkartenfenster der Auswahl angepasst. Die Auswahl kann anschließend für weitere Tabellenfunktionen verwendet werden.

Mit den Tabellen-, Zeilen und Spaltenwerkzeugen lassen sich die Abfrageergebnisse neu anordnen, verschieben oder löschen. Somit ist bei den allgemeinen Abfrageergebnissen eine Lokalisierung der einzelnen Objekte in der Karte durch bloßes "Überfahren" der Tabellenzeilen mit der Maus möglich.

Symbol | Funktion
Tabelle löschen | Tabelle unwiederbringlich aus der Ergebnisliste löschen.
Tabelle ein-/ausblenden | Tabelle ein-/ausblenden.
Karte mit Tabelle abgleichen | Karte mit Tabelle abgleichen.
Zoom auf selektierte Objekte | Zoom auf selektierte Objekte.
 | Auswahl aufheben
Tabelle in Excel weiterverwenden | Tabelle in Excel weiterverwenden.
Nachbarschafts- und Umkreissuche | Nachbarschafts- und Umkreissuche .
Hilfe anzeigen | Hilfe anzeigen.
Zeilen unwiederbringlich aus der Ergebnisliste löschen | Zeilen unwiederbringlich aus der Ergebnisliste löschen.
Zeilen ausblenden | Zeilen ausblenden.
Zeilen wieder einblenden | Ausgeblendete Zeilen wieder einblenden.
Zeilenauswahl umkehren | Zeilenauswahl umkehren.
Zeilen nach oben schieben | Zeilen nach oben schieben.
Zeilen nach unten schieben | Zeilen nach unten schieben.
Auswahl in Session speichern | Auswahl in Session speichern.
Auswahl aus Session laden | Auswahl aus Session laden.
Spalten aufsteigend sortieren | Spalten aufsteigend sortieren.
Spalten absteigend sortieren | Spalten absteigend sortieren.
Spalten unwiederbringlich aus der Ergebnisliste löschen | Spalten unwiederbringlich aus der Ergebnisliste löschen. Dies kann bei größeren Ergebnislisten sinnvoll sein, um Arbeitsspeicherplatz freizusetzen und dadurch die Rechnerleistung zu verbessern.
Spalten ausblenden | Spalten ausblenden.
Spalten wieder einblenden | Ausgeblendete Spalten wieder einblenden.
Spaltenauswahl umkehren | Spaltenauswahl umkehren.
Spalten nach links | Spalten nach links schieben.
Spalten nach rechts | Spalten nach rechts schieben.

Jeder Zeile vorangestellt ist ein Lupensymbol [image] , mit dem der Datensatz zentriert und vergrößert im Hauptkartenfenster dargestellt wird. Die aktuelle Auswahl wird dabei nicht verändert.

Einfügen und Herunterladen von Objekten

Mit der Schaltfläche "Umringpolygon einfügen" werden Zeichenobjekte erzeugt, die den kombinierten Umring aller ausgewählten Ergebnisse darstellen. Die Polygone sind je nach Zugriffsberechtigung nicht generalisiert, nicht verschiebbar und deren Geometrie nicht editierbar. Diese Funktion ist nicht für alle Themen verfügbar.

Die gebildeten Umringpolygone sind generalisierte Objektumringe und werden als Zeichenobjekte behandelt. Sie können für eine weitere Abfrage genutzt werden, indem wiederum der Schaltknopf [image] betätigt wird. Es wird wieder das Menü Nachbarschaftssuche eingeblendet und so kann z.B. abgefragt werden, welches die Nachbargemeinden zu der zuvor selektierten Gemeinde sind.

Optional besteht die Möglichkeit, ganze Objekte als Zeichenobjekte einschließlich der dazugehörigen Attribute in die Karte einzufügen. Je nach themenbezogener Konfiguration ist auch ein sofortiges Herunterladen der Objekte in verschiedenen Formaten/Projektionen möglich. GAIA-MVprofessional lässt sich somit interaktiv als Downloaddienst verwenden.

Über den Objekteditor können eingefügte Objekte nachträglich geometrisch editiert, graphisch ausgestaltet und/oder auch mit Sachdaten beschriftet werden. Es sind normale Zeichenobjekte.

Ergebnisfilter

Abfrageergebnisse können nachträglich eingegrenzt werden. Zu den bisherigen Methoden, ist der Ergebnisfilter per Zeichenfolge hinzugekommen.

Schnellfilter der Ergebnisse

Der eingegebene Text wird dabei in den selektieren Spalten des Ergebnisses gesucht. Sind keine Spalten selektiert, wird über das gesamte Abfrageergebnis gefiltert.

Der Filter kann durch das Klicken auf das rote Symbol neben dem Suchfeld wieder aufgehoben werden.


Bearbeitung von Ergebnistabellen

Abfragen

Bearbeitung der Ergebnistabellen

Die Tabellenbearbeitung läuft vollständig auf dem Client ab, wobei keine Rücksprache mit dem Server ausgeführt wird. Daraus resultiert eine geringe Netzbelastung auch bei sehr großen Ergebnismengen. Sind sie einmal auf dem Client, können sie beliebig bearbeitet werden.

Die folgenden Symbole beziehen sich auf die Funktionen zur Bearbeitung der gesamten Tabelle des Abfrageergebnisses:

Tabelle löschen

Eine Abfrage kann über viele Themen geführt werden. Das Abfrageergebnis enthält somit viele Tabellen. Der Nutzer stellt fest, dass ihn nicht alle interessieren. Er entfernt sie einfach, ohne erst in den Themenmanager zu wechseln, die Abfrage auf Themen einzuschränken und die Abfrage erneut zu stellen.

Tabelle ein- und ausblenden

Zoom auf ausgewählte Objekte

Beim Betätigen dieser Schaltfläche zoomt das Programm auf eine Ausdehnung, die alle in der Tabelle selektierten Objekte umfasst. Ist kein Objekt ausgewählt, zoomt es auf alle.

Auswahl aufheben

Diese Schaltfläche hebt die Auswahl eventuell markierter Abfrageergebnisse auf (Zeilen und Spalten). Die Karte wird im Hintergrund aktualisiert.

Karte bzw. markierte Elemente in der Karte mit der Tabelle abgleichen

In der Karte sind die gewählten Objekte hervorgehoben. Der Nutzer hat aber in der Zwischenzeit mithilfe der Zeilenfunktionen Objekte ausgewählt oder aus dem Ergebnis entfernt. Er möchte, dass sich dies auch in der Karte widerspiegelt. Dazu muss diese Schaltfläche betätigt werden. In der Karte werden nur noch die in der Tabelle verbliebenen Objekte dieses Themas hervorgehoben dargestellt. Die rote Markierung im Hauptkartenfenster zeigt noch die Methode, mit der grafisch abgefragt wurde (z.B. Rechteck bei Abfrage per Box). Fährt der Nutzer mit der Maus über die zu einem Objekt gehörigen Sachdaten im Abfrageergebnis, wird im Hauptkartenfenster das Objekt zur Orientierung für den Nutzer mit Hilfe eines sich in Größe und Farbe verändernden roten Kreises bzw. eines generalisierten Umringpolygons hervorgehoben.

Excel-Export ausgewählter Zeilen und Spalten

Dieses Symbol bietet einen Download der Abfrageergebnisse als Excel-Tabelle an. Der Nutzer kann diese Datei zur weiteren Verarbeitung speichern oder gleich in Excel öffnen.

Nachbarschafts- und Umkreissuche (siehe separater Punkt Abfrage mit Hilfe anderer Objekte)

Die folgenden Symbole beziehen sich auf die Funktionen zur Bearbeitung der Zeilen einer Tabelle. Durch einen Mausklick auf die einzelne Zeile können diese ausgewählt werden. Die ausgewählte Zeile wird eingefärbt.

Markierte Zeile(n) löschen

Markierte Zeile(n) ausblenden

Zeile(n) wieder einblenden

Auswahl der Zeilen umkehren

Markierte Zeile(n) nach oben schieben

Markierte Zeile(n) nach unten schieben

Markierte Zeile(n) in Session speichern

Eine zuvor gespeicherte Auswahl aus Session laden

Speichern in und Laden aus Session beziehen sich dabei lediglich auf die Auswahl (Markierung der Datensätze). Gelöschte Zeilen (Datensätze) werden nicht wieder geladen!

Die folgenden Symbole beziehen sich auf die Funktionen zur Bearbeitung der Spalten einer Tabelle. Durch einen Mausklick auf die Spaltenüberschrift können Spalten ausgewählt werden. Die ausgewählte Spalte wird eingefärbt.

Markierte Spalte(n) aufsteigend sortieren

Markierte Spalte(n) absteigend sortieren

Markierte Spalte(n) löschen

Markierte Spalte(n) ausblenden

Spalten wieder einblenden

Auswahl der Spalten umkehren

Markierte Spalte(n) nach links verschieben

Markierte Spalte(n) nach rechts verschieben

In einigen Themen besteht die Möglichkeit, abgefragte Daten als XML-Datei zu speichern und auch wieder zu laden. Wenn dies nicht frei geschaltet ist, werden die folgenden Symbole auch nicht angezeigt.

Tabelle als XML-Datei abspeichern

Das Diskettensymbol steht für das Speichern des Abfrageergebnisses als XML-Datei. Hierbei erscheint ein Link direkt unter den Symbolen, mit Hilfe dessen der Nutzer (mittels der rechten Maustaste und „Speichern unter“) eine XML-Datei vom Server laden kann.

Hochladen einer XML-Datei

Beim Betätigen des Symbols erscheint unterhalb des Abfrageergebnisses ein Dateidialog zum Einladen einer XML-Datei (im Normalfall springt die Ansicht im Browser nach Betätigen des Buttons zu diesem Dialog). Wird solch eine XML geladen, versucht das Programm eine Verknüpfung zwischen dem bestehenden Abfrageergebnis und dem geladenen Ergebnis zu finden. Wurde eine XML des gleichen Themas geladen, in dem auch noch alle Objekte der XML enthalten sind, wird sich nur die Menge der Ergebnisse ändern. Hat sich in der Zwischenzeit jedoch der Datenbestand geändert, werden nicht mehr gefundene Objekte hervorgehoben. Es empfiehlt sich immer, die XML-Datei so zu benennen, dass der abgefragte Layer im Namen vorkommt, um nicht später einen Layer mit einem anderen verknüpfen zu wollen, die beide nicht das Geringste miteinander zu tun haben.


Abfrage mit Hilfe anderer Objekte

Abfragen

Abfrage mit Hilfe anderer Objekte

Mit Hilfe ausgewählter Objekte eines Abfrageergebnisses können auch Objekte anderer Themen gesucht und abgefragt werden (Nachbarschafts- und Umkreissuche). Es ist der Schaltknopf [image] zu betätigen.

Unterhalb der Schaltknopfleiste erscheint ein kleiner Dialog. Für die Nachbarschaftssuche ist das Thema zu wählen. Zur Klärung von Nachbarschaftsbeziehungen ist auch die Auswahl des gleichen Themas (wie die selektierten Objekte) möglich. Bezogen auf die ausgewählten Objekte kann zusätzlich eine Entfernung (Umkreissuche), in der gesucht werden soll, angegeben werden.

Nach Betätigen des Schaltknopfes „Suche starten“ werden im Abfrageergebnis die Nachbargemeinden aufgelistet und in der Karte farblich markiert.

Wenn der Button „Zeichenelement bearbeiten bzw. löschen“ aktiviert ist, lassen sich über die rechte Maustaste auf dem Objekt (Funktion „Eigenschaften“) bzw. durch Doppelklick auf das Objekt objektbezogene Sachdaten eingegeben und dem Zeichenobjekt zuordnen.


Karteikarte Messen & Zeichnen

Messen, Zeichnen und Beschriftung

Karteikarte " Zeichnen & Messen"

Die Karteikarte „Zeichnen & Messen“ enthält eine Reihe von Schaltknöpfen mit Zeichen- und Editierfunktionen.

Für temporäre Anmerkungen im aktuellen Kartenausschnitt sind folgende Zeichenfunktionen mit aktiver Strecken- und Flächenmessfunktion realisiert:

· das Setzen von Punkten und Beschriftungen (Textblasen),
· das Zeichnen von Linien, Polylinien,
· das Zeichnen von Rechtecken, unregelmäßigen Polygonen und Kreisen.

Anwendungsbeispiele sind das Markieren von Standorten durch Punkt- oder Kreisobjekte und das Einzeichnen von Wanderwegen, Anfahrtsskizzen etc.

Die Beschriftungsfunktion erlaubt außerdem das Setzen von Texten durch den Nutzer.

Folgende Schaltknöpfe stehen für die Zeichen- und Beschriftungsfunktion sowie Speicher- oder Ladefunktion zur Verfügung:
Punkt zeichnen
Punkte kann der Nutzer durch einen Klick mit der linken Maustaste im Hauptkartenfenster setzen.
Linien und Polylinien zeichnen bzw. Entfernung messen
Bei einer Polylinie muss muss jeder Stützpunkt mit einem Klick der linken Maustaste gesetzt werden. Ein Doppelklick schließt die Polylinie ab.
Rechteck zeichnen bzw. Flächen messen
Analog zur Linie bleibt beim Zeichnen eines Rechtecks die Maustaste gedrückt.
Polygon zeichnen bzw. Flächen messen
Bei einem unregelmäßigen Polygon wird jeder Stützpunkt mit einem Klick gesetzt. Ein Doppelklick schließt das Polygon ab.
Kreis zeichnen bzw. Flächen/Kreisradien messen
Beim Kreis wird durch den Klick der Mittelpunkt festgelegt und durch Ziehen mit gedrückter linker Maustaste der Radius bestimmt.
Text setzen
Graphische Ausgestaltung und Geometrie von Zeichenelementen ändern und Verhalten nach dem Zeichnen einstellen
Zeichenelemente speichern
Zeichenelemente laden
Änderungsmodus (Verschieben, Ändern und Löschen von Objekten)
Alle Zeichenelemente markieren und löschen (beim 2. Betätigen auch alle Abfragen)

Beim Zeichnen oder nach der Objektauswahl werden je nach aktuellem Objekttyp (Punkt, Polylinie, Box, Polygon, Zirkel) unten links im Hauptkartenfenster Flächen- und/oder Längen-/Entfernungsangaben eingeblendet. Direkt neben den Angaben können die Einheiten ausgewählt werden. Die Werte werden sofort aktualisiert.

Die Flächengrößen und Streckenlängen werden während des Zeichnens ständig aktualisiert und "laufen" unterhalb der eigentlichen Karte mit. Somit können Flächen bzw. Strecken auch mit realen Größen eingezeichnet werden.

Zeichenfunktion - Einheiten ändern

Unten rechts im Hauptkartenfenster werden die Koordinaten der gewählten Koordinatenanzeige sauber formatiert und mit der notwendigen Anzahl Nachkommastellen angezeigt.


Zeichenmodus

Zeichnen und Beschriftung

Zeichenmodus

Beim Einzeichnen eines Linienzuges oder eines Flächenpolygons befindet sich das System im Zeichenmodus.

Das Zeichnen und Beschriften erfolgt auf dem Client. Netzwerkverkehr findet i.d.R. nicht statt, d.h., der Kartenausschnitt wird nicht nach jedem Zeichnen, Beschriften und Löschen erneut geladen. Während des Zeichnens kann navigiert werden (Pfeiltasten, zoomen per Mausrad).

Es ist aus Sichtbarkeitsgründen mitunter wünschenswert, die Farbe, Strichstärke ändern zu können, ohne das Zeichnen zu unterbrechen. Die rechte Maustaste öffnet beim Digitalisieren ein Menü, welches verschiedene Aktionen zulässt. Die rechte Maustaste muss während der Auswahl aus diesem Menü gedrückt bleiben. Ein Loslassen aktiviert die Schaltfläche, über der der Mauszeiger in diesem Augenblick steht. Der Nutzer kann mit Hilfe dieses Menüs das gesamte Objekt oder den letzten Stützpunkt löschen, die Digitalisierungsrichtung umkehren oder (bei schlechter Sichtbarkeit oder buntem Hintergrund) die Linie verbreitern bzw. Gelb oder Rot einfärben. Mit den Optionen „mit Pfeil“ und „blau gestrichelt mit Ziel“ werden die Endmarker bereits beim Erstellen einer Linie vorausgewählt. Ein Umweg über den Objekteditor ist nicht notwendig.

Zusätzlich kann mittels gedrückter STRG- und x-Taste rechtwinklig gezeichnet werden. So sind i.d.R. rechtwinklige Gebäudekomplexe mit 3 Klicks erfassbar.

Nach dem Einzeichnen eines Objektes wechselt das System standardmäßig in den Editiermodus . Ein Einzeichnen der Objekte mit gedrückter SHIFT-/UMSCHALT-Taste unterbindet den sofortigen Wechsel.

Weitergehende Einstellungen der aktuellen Zeichen-, Editier- und Attributierungsumgebung erfolgen über den Schaltknopf [image] . Im Hauptkartenfenster öffnet sich eine Dialogbox. Das darin enthaltene Menü regelt u.a. die Ausgestaltung von Flächen (Füllfarbe, Transparenz) und Linien (Farbe, Strichstärke, Transparenz, Typ) und das Verhalten nach dem Zeichnen. Für Details siehe die Dokumentation zur Einstellungen . Ein registrierter und angemeldeter Nutzer kann die vorgenommenen Einstellungen mit der Schaltfläche im Titelbereich abspeichern.


Editiermodus (anderungsmodus)

Zeichnen und Beschriftung

Editiermodus (Änderungsmodus)

Über den Schaltknopf [image] wird in den Editiermodus gewechselt.

Im Änderungsmodus kann der Nutzer keine neuen Objekte einzeichnen, sondern nur bereits vorhandene bearbeiten oder löschen. Voraussetzung dafür ist immer ein Selektieren der Objekte.

Zeichenobjekte können mit Hilfe von Mausklicks oder durch Aufziehen einer Auswahlbox aus- oder abgewählt werden. Mit gedrückter Umschalt-/Shifttaste können nacheinander mehrere Objekte aus- oder abgewählt werden. Ausgewählte Objekte sind an den blauen sogenannten Anfassern (Handles) erkennbar.

Mit der Entfernungstaste (Entf oder Delete) auf der Tastatur werden alle selektierten Objekte gelöscht.

Dies ist auch mit einem Klick auf das Löschblatt [image] möglich.

Das sogenannte „Löschblatt“ besitzt dabei eine Doppelfunktion. Es können sowohl Zeichenobjekte als auch Abfrageergebnisse, gesetzte Filter und Textmarkierungen im Hauptkartenfenster entfernt werden. Beim Klick auf den Button wird der Nutzer nochmals aufgefordert, die jeweilige Löschfunktion zu bestätigen:

Die Geometrie der Zeichenobjekte ist auch interaktiv änderbar. Ein gleichzeitiges Editieren mehrerer Objekte ist möglich.

Stützpunkte von Linien- und Polygonzügen können zusätzlich zu den Standardoptionen verschoben, entfernt (rechter Mausklick auf einen Stützpunkt) oder hinzugefügt (rechter Mausklick auf ein Liniensegemt) werden. Das Polylinienmenü enthält zusätzlich die Option „Polylinie splitten“.

Bereits erfasste Linienzüge können mit gedrückter STRG- und y-, x-, c- oder v-Taste im Nachhinein bzgl. rechter Winkel korrigiert werden. Im Internetexplorer ist das gleichzeitige Drücken der STRG-Taste nicht erforderlich.

Kreise und Boxen lassen sich vergrößern bzw. verkleinern, Punkte verschieben. Zum Verschieben eines Objektes muss dieses selektiert sein. Beim Überfahren des Objektes ändert sich der Mauszeiger: . Nun kann mit gedrückter linker Maustaste verschoben werden.

Beim Überfahren eines Stützpunktes ändert sich wiederum der Mauszeiger [image] und der Stützpunkt wird hervorgehoben. Mit der linken Maustaste kann der Nutzer diesen dann verschieben oder mit der rechten Maustaste löschen.

Bei einer Polylinie und einem unregelmäßigen Polygon kann zudem mit einem Rechtsklick der Maus auf eine beliebige Stelle der Linie (bzw. des Umringes) ein Stützpunkt hinzugefügt werden.

Ein Doppelklick auf ein Objekt öffnet ein Dialogfenster mit allen Objekteigenschaften ( Ausgestaltung , Geometrie , Sachdaten und Beschriftung ). Das Featuredialog bietet auch die Möglichkeit, geometrische Operationen zu nutzen und die Geometrie zu beschriften.


Objekteditor

Zeichnen und Beschriftung

Objekteditor

Das Dialogfenster wird mit einem Doppelklick auf einem Zeichenobjekt oder über der rechten Maustaste und dem Menüpunkt „Einstellungen ...“ aufgerufen:

Der Featuredialog besteht aus fünf Karteikarten: Ausgestaltung , Geometrie I , Geometrie II , Sachdaten und Beschriftung .


Ausgestaltung

Zeichnen und Beschriftung - Objektdialog

Ausgestaltung

Unter „Ausgestaltung“ kann der Nutzer die Farben, Transparenz, Strichstärken und –typen ändern.

Des Weiteren kann er auf das Objekt zoomen, es aktualisieren, zur Abfrage benutzen oder es löschen.

Bei Linienobjekten ist es möglich Anfang und Ende einer Linie mit Marker auszustatten:

Die Symbolauswahl erfolgt über den Objekteditor über die Optionen „Linienanfang“ und „Linienende“.

Werden Pfeilsymbole gewählt, sind zusätzlich die Breite (schmal, mittel, breit) und Länge (kurz, mittel lang) variierbar. Die absolute Symbolgröße ergibt sich aus der gewählten Linienstärke und wird automatisch vergeben.

Folgende Symbolauswahl ist im Objekteditor derzeit standardmäßig möglich (vorkonfiguriert):
Pfeil, klassisch und block
Marker, rot, grün, blau mit Schatten
Marker, gelb, hellblau, lila mit Schatten
Stecknadel und Marker
Flagge und Wimpel
Person und Personengruppe


Geometrie I

Zeichnen und Beschriftung - Featuredialog

Geometrie I

Im Karteireiter „Geometrie I“ sind alle geometrischen Eigenschaften gelistet. Es wird eine Koordinatenliste angezeigt, die auch geändert werden kann um Stützpunkte zu verschieben (danach auf der Schaltfläche „in der Karte aktualisieren“ klicken). Die aktuelle Anzeigeprojektion wird hierfür verwendet: die kann unter Einstellungen | Karteneinheiten und Kartenprojektion geändert werden. Eine Schaltfläche zum Überprüfen von eingegebenen Koordinaten ist ebenfalls vorhanden. Die Dezimal- und Trennzeichen können beliebig eingestellt werden, um das Kopieren der Koordinatenliste von/zu anderen Anwendungen zu vereinfachen.
Die Landschaftsfläche in der gewählten Flächenmaßeinheit bzw. Linienlänge oder Radius in die aktuelle Karteneinheit ist unter den Koordinaten gelistet, je nach Objekttyp.

Im Objekteditor können Koordinaten geändert werden. Polylinien können mitunter sehr viele Stützpunkte enthalten. Es wird automatisch hingescrollt und die Zeile blau hervorgehoben.

Es wird eine Beispielkoordinateneingabe (Grad Minuten Sekunden) angeboten.


Geometrie II

Zeichnen und Beschriftung - Featuredialog

Geometrie II

Die Karteikarte „Geometrie II“ enthält Funktionen zur Umwandlung und Teilung der Geometrie und zur Erstellung von Pufferzonen und umschreibender Rechtecke (Extents). Je nach Geometrietyp stehen hier unterschiedliche Operationen zur Verfügung.

Bei der Umwandlung oder Teilung eines Objektes wird der Nutzer gefragt, ob das selektiertes Objekt gelöscht werden soll: mit „OK" wird das aktuelle Objekt gelöscht und mit „Abbrechen" bleibt das Objekt erhalten.

Die jeweiligen erzeugten Objekte werden automatisch selektiert und können beliebig weiterverarbeitet werden. Die neuen Objekte werden gleich wieder entfernt wenn im Kartenfenster Entf oder Delete gedrückt wird: dies kann hilfreich sein z.B. wenn ein Parameter falsch gesetzt wurde.

Die folgenden Konvertierungen sind möglich:

· Betextung in Punkt
· Image in Punkt
· Kreis in Polygon
· Kreis in Punkte
· Linie in Punkte
· Polygon in Polylinie
· Polygon in Punkte
· Polylinie in Polygon
· Polylinie in Punkte
· Rechteck in Polygon
· Rechteck in Punkte

Die Umwandlung von Linien, Polygonen, Polylinien und Rechtecke in Punkte kann an den vorhandenen Stützpunkten, mit einem definierten Abstand oder mit einer bestimmten Anzahl von Punkten erfolgen:

Bei der Teilung von Polylinien und Linien sind vergleichbare Möglichkeiten vorhanden.

Zusätzlich erscheint bei Kreisen, Linien, Polylinien und Polygonen ein Button zum „Erstellen einer umschreibenden Box“. Hierbei wird eine rechteckige Box um das gewählte Geometrieobjekt gesetzt und als neues Objekt angelegt.


Sachdaten

Zeichnen und Beschriftung - Featuredialog

Sachdaten

Der Karteireiter „Sachdaten“ dient zur Speicherung von Attributen und Metadaten. Je nach Profil können sich diese Felder ändern. Dies kann auf reine Bemerkungen beschränkt sein, kann sich aber z.B. auch auf eine komplette Bewertung innerhalb einer Katasterfachschale oder einer Doppik-Bewertung beziehen. Mit der Schaltfläche „Übernehmen“ werden die Sachdaten gespeichert, mit der Schaltfläche „Zurücksetzen“ zu den zuletzt gespeicherten Werten zurückgesetzt.


Beschriftung

Zeichnen und Beschriftung - Featuredialog

Beschriftung

Die Karteikarte „Beschriftung“ enthält Funktionen zur Beschriftung der Geometrie. Die Beschriftung wird in Form von Betextungsobjekten erstellt, die nachher auch verschoben und editiert werden können.

Die folgenden Beispiele zeigen die Möglichkeiten zur Beschriftung:

Textbox mit Gesamtlänge am Mittelpunkt Textbox mit Gesamtlänge am Mittelpunkt | Sprechblase mit Verschlagwortung am Startpunkt Sprechblase mit Verschlagwortung am Startpunkt
Sprechblasen mit Entfernungsangaben an Stützpunkten Sprechblasen mit Entfernungsangaben an Stützpunkten | Textboxen mit Entfernungsangaben in 300m Abstand Textbox mit Entfernungsangaben in 300m Abstand
Sprechblasen mit Koordinaten an Stützpunkten Sprechblasen mit Koordinaten an Stützpunkten | Fortlaufende Nummerierung an Stützpunkten Textboxen mit fortlaufender Nummerierung an Stützpunkten
Textbox mit Fläche
am Mittelpunkt (Centroid)
Fläche am Mittelpunkt (Centroid)
Segmentlängen

Die erzeugten Beschriftungsobjekte werden gleich selektiert - die zuletzt erzeugte Beschriftung wird gleich wieder gelöscht, wenn im Kartenfenster Entf oder Delete gedrückt wird. Dies kann hilfreich sein, wenn z.B. ein Parameter falsch eingegeben wurde.

Liegt der Schwerpunkt eines Polygons außerhalb, wird das Polygon auch innerhalb beschriftet.


Zwischenablage von Koordinaten

Zeichnen und Beschriftung

Zwischenablage von Koordinaten

Nach dem Einzeichnen, Ändern oder Auswählen von Objekten werden die Koordinaten der im Auswahlsatz befindlichen Objekte sofort in die Zwischenablage kopiert. Sie können somit durch einfaches Einfügen (STRG-V oder SHIFT-Einfg) zügig in andere Anwendungen übernommen werden.

Diese Funktionalität muss beim ersten Zugriff ggf. noch aktiviert werden. Nach der Fertigstellung eines Objektes erscheint folgendes Info-Fenster:

Ein Klick auf „Aktivieren“ und die anschließende Bestätigung „Zugriff auf Zwischenablage zulassen“ erlauben die Speicherung der Objektkoordinaten in der Zwischenablage.

Sollte in der profilbezogenen Konfigurationsdatei dieser Automatismus standardmäßig abgeschaltet sein, so kann der Nutzer obige Option auch über den Karteireiter „Zeichnen“ über den Schaltknopf [image] „Graphische Ausgestaltung und Zeichenumgebung setzen“ im Dialog nachträglich jederzeit aktivieren oder deaktivieren.

Im Internet Explorer werden die Koordinaten im Hintergrund mitgeführt und lassen sich mit STRG-V oder SHIFT-Einfg in andere Anwendungen übertragen.

Von anderen Browsern, beispielsweise Mozilla Firefox, ist die Verwendung der Zwischenablage aus Sicherheitsgründen deaktiviert. Aus diesem Grund ist in diesen Browsern ein zusätzliches Fenster im oberen Teil der Karte eingefügt, in dem die Koordinaten als Text zu finden sind. Diese lassen sich mit STRG-A komplett markieren und mit STRG-C in die systemeigene Zwischenablage kopieren. Nun stehen auch diese Koordinaten anderen Anwendungen zur Verfügung.


Speichern und Laden von Zeichenobjekten

Zeichnen und Beschriftung

Speichern und Laden von Zeichenobjekten

Zeichenobjekte können auf dem Rechner des Nutzers gespeichert und wieder geladen werden. Ebenso lassen sich eigene Daten wie ESRI Shapefiles, GPS-Tracks, Google Earth KML- bzw. KMZ-Dateien, usw. einbinden. Siehe dazu Import/Export .


ubersicht der Im- und Exportmoglichkeiten

Import / Export

Übersicht der Im- und Exportmöglichkeiten

In der Karteikarte "Zeichnen" erfolgt der Import und Export (Laden und Abspeichern) von Dateien bzw. Zeichenelementen mit den Schaltknöpfen [image] und [image] .

Es können sowohl zuvor erstellte als auch externe Daten geladen werden. Dabei werden zurzeit folgende Formate unterstützt:

· ArcINFO ASCII-Coverage (.e00) [nur import]

· Komma-getrennt (.csv)

· Microstation DGN (.dgn) [nur import]

· AutoCAD DXF (*.dxf) [nur import]

· ESRI Shapefile (.shp, .shx, .dbf, .prj, .png, .gif, .jpg, .jpeg)

· GeoRSS-GML (.xml) [nur import]

· GML Geography Markup Language (.gml) [nur import]

· GPS-Geräte Tracks, Routen und Wegepunkte (.gpx) [nur import]

· Google Earth Keyhole Markup Language (.kml, .kmz, .png, .gif, .jpg, .jpeg) [nur import]

· Mapinfo (.tab, .map, .id, .ind, .dat, .mif,.mid) [nur import]

· AFIS-ALKIS-ATKIS Normbasierte Austauschschnittstelle NAS (.nas, .xml) [nur import]

· TOP50 der deutschen Landesvermessung OVL (.ovl, .bmp, .png, .gif)

· S57 Elektronische Seekarte (.000) [nur import]

Unter der Karteikarte „ Abfragen “ werden in den Ergebnisfenstern Tabellen erstellt, die sich in das Excel-Format exportieren lassen (siehe Bearbeitung von Ergebnistabellen ).

Weitere Import-Möglichkeiten gibt es im Bereich der WMS-Dienste im Themenmanager. Hier können webbasierte Kartendienste von anderen GEO-Portalen hinzu geladen werden (siehe " WMS-Dienste ").


Import Themen und Zeichenobjekte

Import / Export

Import Themen und Zeichenobjekte

Dateien können sowohl als Themen als auch Vektoren (Zeichenobjekte) importiert werden. Im ersten Fall werden die Daten wie existierende Layers im Themenbaum sichtbar. Als Zeichenobjekte können die importierten Daten eventuell editiert und wieder exportiert werden.

Die genaue Gestaltung des Importdialogs hängt von dem zu importierenden Dateiformat und der Verfügbarkeit eines Flash-Plugins ab. Im Allgemeinen ist es aber dreigeteilt:

Im obersten Teil kann das Dateiformat eingestellt werden. Der mittlere Teil dient zum Auswahl und Hochladen der Dateien und im unteren Teil kann die Projektion und Art des Datenimports festgelegt werden.

Wichtig: Ohne die richtige Angabe des Koordinatensystems ist eine korrekte Projektion der Importdatei auf das Kartenbild im Hauptkartenfenster nicht gewährleistet!

Die Option zur Dateneinbindung als „Thema“ legt im Themenbaum einen neuen Ordner mit dem gewählten Namen an und die hochgeladene Shape-Datei wird analog zu den anderen Themen aufgerastert und kann nur betrachtet werden.

Bei der Option „Vektoren“ legt das Programm die Daten als Zeichenobjekte über das Kartenbild. Je nach gewählter Einstellung sind diese Objekte auch editierbar.

Der Button „Importieren“ schließt das Fenster und importiert die Daten.


Auswahl der Datei

Import / Export - Import Themen und Zeichenobjekte

Auswahl der Datei

Prinzipiell können Dateien entweder einzeln ausgewählt und hochgeladen werden, oder auch als ZIP-Archiv zusammengepackt hochgeladen werden. In diesem Fall können auch mehrere Datensätze gleichzeitig hochgeladen werden, und auch zusätzliche Dateien integriert werden.

Bei manchen geografischen Dateiformaten (Shapedatei, Mapinfo, usw.) besteht ein Datensatz aus mehreren Dateien. In diesen Fällen müssen alle notwendigen Dateien (z.B. .shp, .shx, .dbf) hochgeladen werden, entweder einzeln oder als ZIP-Archiv.

Wenn das Flash-Plugin vorhanden ist, werden die Dateien bequem über einen einzigen Button ausgewählt.

Hier wählt der Nutzer entweder eine ZIP-Datei oder über eine Mehrfachauswahl die Bestandteile des Datensatzes auf einmal aus.

Ohne Flash ist leider nur die Auswahl jeweils einer Datei möglich, also entweder einer ZIP-Datei oder jede Bestandteil eines Datensatzes einzeln. In diesem Fall werden Felder für die einzelnen Bestandteilde des Dateiformats zur Verfügung gestellt.

Es lassen sich auch ganze Projektstrukturen in einem Arbeitsschritt hinzufügen.

Sie können ihr gesamtes Projektverzeichnis in einer ZIP-Datei ablegen und anschließend in GAIA laden. Beim Laden der ZIP-Datei in die Session werden alle beinhalteten Datensätze ergänzt. Wenn man die Datensätze als Themen lädt, sind diese anschließend im Themenbaum verfügbar. Dabei werden Unterordner und ZIP-Dateien als Ordner im Themenbaum übernommen.

Hinweis: Das Laden von Datensätze ist eventuell eingeschränkt. So kann eine Begrenzung auf die Anzahl der Dateisätze für eine Sitzung oder die Größe der hochgeladenen Dateien bestehen. Bei Fragen wenden Sie sich bitte an den Administrator.


Export von Zeichenobjekten

Import / Export

Export von Zeichenobjekten

Beim Export selektierter Zeichenobjekte kann die gewünschte Projektion, in der das Element gespeichert werden soll, angegeben werden. Weiterhin ist ein Dateiname anzugeben.

Beim Export werden alle selektierten Objekte als ESRI-Shapedateien zum Download angeboten. Je nach ausgewähltem Typ können es bis zu drei Shapefile-Sätze sein (Punkte, Linien, Flächen). Neben den einzelnen Bestandteilen dieser Shape-Dateien wird auch eine Version als ZIP-Archiv zur Verfügung gestellt. Es besteht die Möglichkeit, der ZIP-Datei einen anderen Namen zu geben, welcher dann auch den Shape-Bestandteilen voran gestellt wird.

Zusätzlich werden die Daten als Komma-getrennt (CSV) und OVL-Datei angeboten. Diese beiden Versionen sind ebenfalls im ZIP-Archiv enthalten.

Zum Download ist die gewünschte Datei anzuklicken und kann danach lokal geöffnet und/oder gespeichert werden.


Druck

Drucken

Druck

Der Schaltknopf für den Druck [image] befindet sich rechts im Hauptkartenfenster .

GAIA-MVprofessional bietet einen maßstabsabhängigen, hochauflösenden Druck. Sowohl Daten aus sichtbaren Themen als auch die aktuellen Zeichenelemente werden gedruckt. Somit kann GAIA-MVprofessional für die Herstellung eigener ausgedruckter Karten auf Basis der über Webdienste gelieferten Basiskarten, unter Berücksichtigung der jeweiligen Nutzungsbedingungen, verwendet werden.

Außerdem gibt es vordefinierte Eingabefelder für diverse Optionen und eigene Möglichkeiten für die Gestaltung des Layouts mit Kartenelementen wie z.B.:

· Titel und Untertitel,
· Maßstabsleiste,
· Rahmen,
· Logo,
· Stempelfeld,
· Copyright u. v. m.

Allgemeine Einstellungen für den Druck können in den Einstellungensbereichen Druck - Kartenelement und Druck - Seitenausgestaltung definiert werden. Außderdem können die Einstellungen für jeden Druck individuell angepasst werden.

Im ersten Schritt muss der Druckmaßstab ausgewählt werden und der Inhalt der Kartenelemente definiert. Als Maßstab werden der aktuelle Kartenmaßstab des Hauptkartenfensters und ein nach oben und ein nach unten abgerundeter Maßstab angeboten. Die Defaultwerte und -sichtbarkeit für die Kartenelemente kann in Einstellungen Druck - Kartenelement geändert werden und für angemeldete Benutzer im Profil gespeichert werden.

Im nächsten Schritt wird das Layout gewählt. Die verfügbaren Papiergrößen können je nach Systemeinstellungen unterschiedlich sein. Defaulteinstellungen können im Einstellungsbereich Druck - Seitenausgestaltung geändert und im Nutzerprofil gespeichert werden.

Mit der Funktion "Fertigstellen" können die Auswahldialoge übersprungen werden. Hierbei werden die Standard-Einstellungen beibehalten.

Der Layoutmodus "Web" dient zum Export eines Bildes (anstatt .pdf) im Format gif, png oder jpeg. Hier kann Qualität und Größe des zu erzeugenden Bildes angepasst werden. Diese Funktion steht nicht allen Benutzern zur Verfügung. Standard ist die Layoutversion "Druck" zum erzeugen von PDF-Dokumenten.

Nach Eingabe der Parameter besteht anhand der Schaltfläche „Kartenausschnitt ändern“ die Möglichkeit, den druckbaren Kartenausschnitt anzuzeigen und ggf. zu verschieben.

Ein Klick auf die Schaltfläche "Weiter" erstellt dann eine Druckvorschau. In diesem Fenster erscheinen die einzelnen Kartenbestandteile, hierzu gehören je nach Konfiguration der Kartentitel, der Untertitel, das Stempelfeld, die Legenden, die Maßstabsleiste sowie der Copyrightvermerk. In der Regel können die Kartenbestandteile in der Druckvorschau verschoben und bis auf den Copyrightvermerk auch entfernt werden.

Oben links im Druckvorschaufenster ist ein Schaltknopfblock enthalten, der u.a die Ausgabe in ein PDF-Dokument bewirkt. Dieser Schaltknopfblock kann bei Bedarf ebenfalls verschoben werden.

Abhängig von der Konfiguration kann der Nutzer den Dateinamen editieren, eine kurze Beschreibung hinzufügen, eventuell zuvor erzeugte PDF-Druckdokumente zusammenfügen und das Dokument anschließend durch einen Klick herunterladen.

Das Dokument wird in einem Ordner abgelegt und kann später (solange der Benutzer eingeloggt bleibt) wieder verwendet werden. Somit besteht während der Sitzung die Möglichkeit, zuvor erstellte Druckdateien mit der aktuell erzeugten Datei zu einem PDF-Dokument zusammenzufügen.

Siehe auch: Hinweise zum Umgang mit PDF-Dokumenten .


Hinweise zum Umgang mit PDF-Dokumenten

Drucken

Hinweise

Zum Öffnen der PDF-Dokumente benötigen Sie den Acrobat Reader (kostenfrei).

Acrobat reader laden aktuellen Acrobat Reader laden

Die erzeugten PDF-Dokumente können sehr groß werden. Je nach Auslastung und Netzzugang kann das Laden eine Weile dauern.

PDF-Dokumente im Browserfenster öffnen

Erscheinen die PDF-Dokumente nicht im separatem Browserfenster, müssen Sie eventuell die Einstellungen des Acrobat Readers ändern. Öffnen Sie hierzu den Acrobat Reader. Über die Menüpunkte "Bearbeiten","Voreinstellungen","Internet" gelangen Sie zur Web-Browser-Option "PDF in Browser anzeigen". Diese muss aktiviert werden.
Wir empfehlen die Anzeige der PDF-Dokumente außerhalb eines Browserfensters vorzunehmen.

PDF-Dokumente außerhalb des Browserfensters öffnen

Das direkte Öffnen eines PDF-Dokumentes im Acrobat Reader aus einer Internetseite heraus ist möglich. Der Acrobat Reader wird hierbei nicht erst in den Browser geladen, um abschließend das Dokument zu öffnen.

Voraussetzung ist die Deaktivierung der Web-Browser-Option "PDF in Browser anzeigen" des Acrobat Readers. öffnen Sie hierzu den Acrobat Reader. Über die Menüpunkte "Bearbeiten","Voreinstellungen","Internet" gelangen Sie zu obiger Option.

Wir empfehlen für das Öffnen von großen PDF-Dokumenten, die Dokumente erst auf die Festplatte zu laden und dann zu öffnen. Hierzu klicken Sie bitte auf den Link zum PDF-Dokument nicht mit der linken, sondern mit der rechten Maustaste, und wählen dann aus dem angebotenen Menü den Punkt "Ziel speichern unter".

Häufig gestellte Fragen

Warum ist mein Kartenausdruck nicht maßstabsgerecht?


Karteikarte Extras

Extras

Extras

Die Karteikarte „Extras“ enthält standardmäßig die Vergleichsfunktion , ein Werkzeug für die Einstellungen und die Funktion zur Erzeugung eines Links zu einer GAIA-Instanz mit den aktuellen Einstellungen. Erweiterte Systeme können hier aber weitere Funktionalitäten zur Verfügung stellen.
Vergleichsansicht ein/aus
Einstellungsdialog öffnen
Link erzeugen


Vergleichen

Extras

Vergleichen

Im Karteireiter „Extras“ kann mit Hilfe des Schaltknopfes [image] die Vergleichsansicht ein- oder ausgeschaltet werden.

Beim Einschalten werden die aktuellen Themen in einer Liste gespeichert und stehen ab diesem Moment als Vergleichsansicht (overlay) zur Verfügung. Die Sichtbarkeit der Themen der darunterliegenden normalen Ansicht (basis) können wie immer über den Themenbaum gesteuert werden. Im Hauptkartenfenster wird nach dem Einschalten eine entsprechende Hilfemeldung eingeblendet.

An den Rändern der Karte erscheinen Schieberegler zum Einschränken der Sichtbarkeit der Vergleichsansicht. Die Sichtbarkeit kann aus allen vier Himmelsrichtungen heraus eingeschränkt werden.

Mit Hilfe eines zusätzlichen Reglers auf der rechten Seite kann die Transparenz der Vergleichsansicht gesteuert werden.


ubersicht der Einstellungen

Extras - Einstellungen

Übersicht der Einstellungen

Die Einstellungen sind nicht nur für den versierten Nutzer interessant, sondern kann auch die Performance der Anwendung beschleunigen.

Die Einstellungen können über das Einstellungswerkzeug aus der Karteikarte Extras eingesehen und geändert werden. Die Einstellungen sind in 7 Bereiche unterteilt:

· Karteneinheiten und Kartenprojektion

· Abfrageumgebung

· Zeichen-, Editier- und Attributierumgebung

· Technische Umgebung

· Themenmanager

· Druck - Kartenelemente

· Druck - Seitenausgestaltung

Die vorgenommenen Einstellungen werden immer mit Betätigen der Schaltfläche "Übernehmen" im jeweiligen Bereich wirksam.


Karteneinheiten und Kartenprojektion

Extras - Einstellungen

Karteneinheiten und Kartenprojektion

In diesem Bereich können folgenden Einstellungen geändert werden:

· Auswahl der Einheiten für die Flächen- und Längenmessung

· Auswahl des Zoomfaktors für statische Zoomfunktionen und dynamisches Verkleinern des Kartenausschnittes (Zoom minus)

· Auswahl der Kartenprojektion

· Auswahl Koordinatenanzeige der Koordinatenanzeige

· Aktivsetzen mitlaufender Koordinatenanzeigen, Flächen- und Längenberechnungen

Ein Abschalten mitlaufender Koordinaten , der Flächen- und Entfernungsbestimmungen empfiehlt sich in einer Terminalumgebung (z. B. Citrix). Ein Bildschirmflimmern wird damit verhindert. Die Endergebnisse der Koordinaten werden trotzdem angezeigt und können in andere Anwendungen übernommen werden.

Der Nutzer kann die kartographische Abbildung während einer Sitzung frei wählen. Vorkonfiguriert sind folgende Abbildungen:

· Bessel (RD/83) Gauß-Krüger, 3 Grad Streifensystem, 3. Streifen,
· Bessel (RD/83) Gauß-Krüger, 3 Grad Streifensystem, 4. Streifen,
· Bessel (RD/83) Gauß-Krüger, 3 Grad Streifensystem, 5. Streifen,
· Krassowski (S42/83) Gauß-Krüger, 3 Grad Streifensystem, 4. Streifen,
· Krassowski (S42/83) Gauß-Krüger, 3 Grad Streifensystem, 5. Streifen,
· ETRS89, UTM, 6 Grad Streifensystem, Zone 32 mit führender 32,
· ETRS89, UTM, 6 Grad Streifensystem, Zone 32 ohne führende 32,
· ETRS89, UTM, 6 Grad Streifensystem, Zone 33 mit führender 33,
· ETRS89, UTM, 6 Grad Streifensystem, Zone 33 ohne führende 33.

Für die Koordinatenanzeige stehen folgende Referenzsysteme zur Verfügung:

· WGS84, geografisch, Dezimalgrad
· WGS84, geografisch, Grad-Minute
· WGS84, geografisch, Grad-Minute-Sekunde
· Bessel (RD/83) Gauß-Krüger, 3 Grad Streifensystem, 3. Streifen,
· Bessel (RD/83) Gauß-Krüger, 3 Grad Streifensystem, 4. Streifen,
· Bessel (RD/83) Gauß-Krüger, 3 Grad Streifensystem, 5. Streifen,
· Krassowski (S42/83) Gauß-Krüger, 3 Grad Streifensystem, 4. Streifen,
· Krassowski (S42/83) Gauß-Krüger, 3 Grad Streifensystem, 5. Streifen,
· Krassowski (S42/83) Gauß-Krüger, 6 Grad Streifensystem, 2. Streifen,
· Krassowski (S42/83) Gauß-Krüger, 6 Grad Streifensystem, 3. Streifen,
· ETRS89, UTM, 6 Grad Streifensystem, Zone 32 mit führender 32,
· ETRS89, UTM, 6 Grad Streifensystem, Zone 33 ohne führende 32,
· ETRS89, UTM, 6 Grad Streifensystem, Zone 32 mit führender 33,
· ETRS89, UTM, 6 Grad Streifensystem, Zone 33 ohne führende 33.

Voreinstellungen können vom Geoadministrator vorgenommen werden. Dazu gehört auch die Möglichkeit, andere Koordinatensysteme einbinden zu können.


Abfrageumgebung

Extras - Einstellungen

Abfrageumgebung

Die Wahl einer anderen Farbe für ausgewählte Objekte ist sinnvoll, wenn die Legendenobjekte in der gleichen Farbe gezeichnet werden wie die Auswahlfarbe. Standardmäßig ist die Farbe rot als Auswahlfarbe definiert.

Das Zeichnen von nur ausgewählten Objekten ist mitunter zur Lesbarkeit der Abfrageergebnisse in der vom Server gelieferten Karte sinnvoll, vor allem wenn über viele Themen hinweg abgefragt wird. Standardmäßig werden alle Objekte nach ihrer Legende gezeichnet und die ausgewählten Objekte in der Auswahlfarbe hervorgehoben.


Zeichen-, Editier- und Attributierumgebung

Extras - Einstellungen

Zeichen-, Editier- und Attributierumgebung

Die Option „Übertragung auf selektierte Objekte“ übernimmt die getätigten Einstellungen nur auf selektierte Objekte, während eine aktivierte Option „Standard für neue Objekte“ alle Änderungen auch für neue Objekte wirksam werden lässt.

Bei Aktivierung der Option „nach dem Zeichnen: à Objekte sofort editierbar“ ist jedes Objekt nach dem Zeichnen sofort editierbar, d.h. es ist selektiert und der Nutzer kann die Geometrie ändern. Zum Zeichnen eines neuen Objektes muss dieses jedoch erst wieder in der Navigationsleiste aktiviert werden. Sollen also mehrere Objekte hintereinander gezeichnet werden, muss diese Option deaktiviert werden!

Je nach Profil und Berechtigung können zu einem Objekt diverse Attribute (z. B. IDs oder Bemerkungen) gespeichert werden. Bei Aktivierung der Option „nach dem Zeichnen à sofortige Attributeingabe möglich“ erscheint nach jedem gezeichneten Objekt ein Eingabeformular für diese Attribute bzw. für die Verschlagwortung. Bei ausgeschalteter Option kann die Attributeingabe sofort geöffnet werden, wenn die STRG-Taste beim Zeichnen gehalten wird.

Mit der Option „Objekte fangen“ springt die aktuelle Mausposition auf einen bereits gezeichneten Stützpunkt eines anderen Objektes, sobald eine gewisse Toleranzgrenze unterschritten wurde. Dies ist sehr nützlich, um z.B. eine Linie nach der Beendigung einer Digitalisierung ansatzlos fortzusetzen.

Siehe die Dokumentation zur Zwischenablage von Koordinaten für weitere Information zu dieser Einstellung.


Technische Umgebung

Extras - Einstellungen

Technische Einstellungen

In einem Browser kann programmtechnisch nur die Anzahl der Pixel in der Breite und Höhe ermittelt werden. Für die exakte Druckausgabe müssen allerdings die Größen der Betextungen, Symbole, Linienstärken in metrische Einheiten (mm) umgerechnet werden. Dazu wird die Bildschirmauflösung (Punkte pro Zoll) benötigt.

Die heutigen Bildschirmauflösungen reichen von ca. 30 bis über 300 Punkte pro Zoll. Hinzu kommen virtuelle Auflösungen in Terminals (Citrixumgebungen). Daraus resultieren Fehler in der Aufbereitung der Karten für den Druck.

Der Nutzer kann mit Hilfe eines Schiebereglers und einem Lineal eine i.d.R 3 cm lange Linie einstellen oder die Bildschirmauflösung direkt eingeben (Punkte pro Zoll). Zieht der Nutzer am Schieberegler, ändert sich automatisch die Monitorauflösung. Diese Einstellung ist unter einem Namen speicherbar. Es können mehrere benannte Auflösungen für die verschiedenen Geräte angelegt werden.

Unabhängig davon sind zur Unterstützung der Barrierefreiheit Text-, Symbolgrößen in Stufen wählbar (sehr groß, groß, normal, klein, sehr klein).


Druck - Kartenelemente

Extras - Einstellungen

Druck - Kartenelemente

Hier kann die Gestaltung gedruckter Karten bestimmt werden. Einzelne Kartenelemente können ein- und ausgeschaltet werden, und deren Inhalte geändert. Die hier definierten Defaultwerte können bei jeden Kartendruck angepasst werden.

Für die Textfelder stehen folgende Templates (Schlüsselworter) zur Verfügung, die beim Druck mit den jeweiligen Inhalt entsprechend ersetzt werden:
[date] | Druckdatum
[scale] | Kartenmaßstab
[bearbeiter] | Name des aktuellen Benutzers
[telefon] | Telefonnummer des aktuellen Benutzers
[mail] | Emailadresse des aktuellen Benutzers
[fax] | Faxnummer des aktuellen Benutzers
[az] | Aktenzeichen
[internet] | Internetseite des aktuellen Benutzers
[department] | Abteilung des aktuellen Benutzers


Druck - Seitenausgestaltung

Extras - Einstellungen

Druck - Seitenausgestaltung

Hier kann die Standardpapiergröße und -orientierung eingestellt werden. Die verfügbaren Papiergrößen können nach Systemeinstellungen und Nutzerberechtigung unteschiedlich sein.

Um einen maßstabstreuen Druck zu kriegen ist es sinnvoll, die Druckränder an dem Druckbereich des eigenen Druckers anzupassen und die PDF-Datei dann ohne Seitenanpassung zu drucken.

Die Druckqualität bestimmt maßgeblich die Größe der erzeugten PDF-Datei: eine niedrigere Druckqualität kann daher bei einer langsamen Netzverbindung, begrenzte Serverkapazitäten und/oder größere Papierformate sinnvoll sein.


Nutzereinstellungen speichern und zurucksetzen

Extras

Nutzereinstellungen speichern und zurücksetzen

Ein registrierter Nutzer kann vorgenommene Einstellungen abspeichern.

Das Speichern bezieht sich auf folgende Eigenschaften:

· Titel ein/aus

· Karteneinheiten und Kartenprojektion

· Abfrageumgebung

· Zeichen-, Editier- und Attributierumgebung

· Technische Umgebung

· Themenmanager bzw. Themenbaum

· Druck - Kartenelemente

· Druck - Seitenausgestaltung

Die Werkseinstellungen können mit der Schaltfläche unter Extras / Einstellungen wiederhergestellt werden:

Außerdem können Einstellungen der einzelnen Bereiche mit den Schaltflächen in den jeweiligen Dialogfenstern gespeichert und zurückgesetzt werden.


Link erzeugen

Extras

Link erzeugen
(Diese Funktion ist nicht standartmäßig vorhanden.)

Mit der Schaltfläche "Link zum Aufruf von GAIA erstellen" kann ein Link erzeugt werden,mit dem GAIA-MVprofessional mit den aktuellen Einstellungen (Maßstab, Zoomstufe, Kartenausschnitt, Projektion) aufgerufen werden kann.


Hinweise und bekannte Probleme/Bugs

Hinweise und bekannte Probleme/Bugs

Hinweise und bekannte Probleme/Bugs


Warum sehe ich keine Zeichenobjekte?

FAQ

Warum sehe ich keine Zeichenobjekte?

F: Warum sehe ich keine Zeichenobjekte? JavaScript ist aktiviert.

A: Überprüfen Sie bitte die Sicherheitseinstellungen des Browsers (siehe Kapitel Sicherheitseinstellungen)

F: Alle Sicherheitseinstellungen wurden befolgt, trotzdem wird GAIA mit dem Internet Explorer nicht geladen.

A: In der Standard- und Vollinstallation des IE ist "VML Rendering" bereits integriert. In der Minimal- oder Benutzerdefinierten Installation wurde diese Funktion ggf. weg gelassen. VML Rendering ist für korrekte Funktionsweise erforderlich. Kontaktieren Sie den Administrator.


Warum ist mein Kartenausdruck nicht masstabsgerecht?

FAQ

Warum ist mein Kartenausdruck nicht maßstabsgerecht?

F: Warum ist mein Kartenausdruck nicht maßstabsgerecht?

A: Achten Sie bitte beim Druck aus dem Explorer (Druckvorschau) oder dem Acrobat-Reader heraus darauf, dass Sie keine Skalierung der Seiteninhalte an die Seitengröße zulassen. Vorhandene Schaltflächen "An die Seitengröße anpassen", "Vergrößern", "Skalieren" o.ä. abschalten.